• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            coreBugZJ

            此 blog 已棄。

            Vote, FZU 2011年3月月賽之 F, FZU 2015

            Problem 2015 Vote

            Time Limit: 1000 mSec    Memory Limit : 32768 KB

            Problem Description

            Here are n Candidates in one election. Every Candidate could vote any one (of course himself/herself). In this election, the one who gets more than half of n become the winner! However, sometimes no winner could be determined (No one gets more than half of n votes)!

            Now you are given the number of Candidates and the final winner m, here if m is equal to -1, then it means that no one wins, otherwise m is the index of the Candidate. (The index of Candidates is 0, 1, 2, … n – 1 respectively) Abcdxyzk wants to know the number of possible ways of the final result if the winner if m. (m = -1 for no winner of course) However, the answer maybe large, so abcdxyzk just want the remainder of the answer after divided by 1000000007.

            Input

            There are several test cases.

            For each case, only two integers n and m in a single line indicates n Candidates and the final winner m. (1 <= n <= 100, -1 <= m < n)

            Output

            For each test case, output the number of possible ways of the final election!

            Sample Input

            2 1
            3 -1
            4 1

            Sample Output

            1
            1
            4

            Hint

            In case 1, only one possible ways of the final result because both 0 and 1 vote to 1.

            In case 2, only one possible ways of the final result because all of 0, 1, and 2 get one vote.

            In case 3, there are 4 possible ways of final result:

            (1) 0: 1 (vote(s)) 1: 3 (vote(s)) 2: 0 (vote(s)) 3: 0 (vote(s))

            (2) 0: 0 (vote(s)) 1: 3 (vote(s)) 2: 1 (vote(s)) 3: 0 (vote(s))

            (3) 0: 0 (vote(s)) 1: 3 (vote(s)) 2: 0 (vote(s)) 3: 1 (vote(s))

            (4) 0: 0 (vote(s)) 1: 4 (vote(s)) 2: 0 (vote(s)) 3: 0 (vote(s))

            Source

            FOJ有獎月賽-2011年03月


            組合數(shù)。

            我的代碼:
             1 #include <stdio.h>
             2 
             3 typedef  long  long  Lint;
             4 
             5 #define  L  203
             6 #define  MOD  1000000007
             7 
             8 int c[ L ][ L ];
             9 
            10 int main() {
            11         int n, m, i, j, ans;
            12         for ( i = 0; i < L; ++i ) {
            13                 c[ i ][ 0 ] = c[ i ][ i ] = 1;
            14                 for ( j = 1; j < i; ++j ) {
            15                         c[ i ][ j ] = ( c[ i - 1 ][ j - 1 ] + c[ i - 1 ][ j ] ) % MOD;
            16                 }
            17         }
            18         while ( scanf( "%d%d"&n, &m ) == 2 ) {
            19                 if ( m < 0 ) {
            20                         ans = ( c[n+n-1][n] + (Lint)(MOD-c[(n-1)+(n-n/2-1)][n-1]) * n ) % MOD;
            21                 }
            22                 else {
            23                         ans = c[ (n-1+ (n-n/2-1) ][ n-1 ];
            24                 }
            25                 printf( "%d\n", ans );
            26         }
            27         return 0;
            28 }
            29 

            posted on 2011-03-23 22:46 coreBugZJ 閱讀(1462) 評論(0)  編輯 收藏 引用 所屬分類: ACM

            久久久久久国产精品免费免费 | 久久精品中文字幕有码| 亚洲国产成人久久综合碰碰动漫3d| 99国产精品久久久久久久成人热| 99久久婷婷国产综合精品草原| 亚洲精品综合久久| 97r久久精品国产99国产精| 久久久久国产精品三级网| 久久天堂AV综合合色蜜桃网| 久久久久国产| 伊人久久综合热线大杳蕉下载| 久久婷婷五月综合97色直播| 99久久伊人精品综合观看| 午夜不卡久久精品无码免费| 久久精品18| 91精品国产综合久久香蕉 | 国产精品岛国久久久久| 国产欧美久久久精品影院| 久久er国产精品免费观看2| 国产成人精品综合久久久| 91久久精品无码一区二区毛片| AAA级久久久精品无码片| 亚洲av成人无码久久精品| 久久国产劲爆AV内射—百度| 亚洲精品综合久久| 天天影视色香欲综合久久| 国产成人精品久久一区二区三区av| 久久久久人妻精品一区二区三区 | 一本一道久久精品综合| av无码久久久久久不卡网站| 日日躁夜夜躁狠狠久久AV| 波多野结衣久久一区二区| 久久久久av无码免费网| 性做久久久久久免费观看| 久久精品无码一区二区app| 久久久WWW成人免费毛片| 午夜视频久久久久一区| 久久中文字幕精品| 国产成人精品综合久久久久 | 国内精品久久久久久久涩爱| 久久精品99无色码中文字幕|