• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            coreBugZJ

            此 blog 已棄。

            Vote, FZU 2011年3月月賽之 F, FZU 2015

            Problem 2015 Vote

            Time Limit: 1000 mSec    Memory Limit : 32768 KB

            Problem Description

            Here are n Candidates in one election. Every Candidate could vote any one (of course himself/herself). In this election, the one who gets more than half of n become the winner! However, sometimes no winner could be determined (No one gets more than half of n votes)!

            Now you are given the number of Candidates and the final winner m, here if m is equal to -1, then it means that no one wins, otherwise m is the index of the Candidate. (The index of Candidates is 0, 1, 2, … n – 1 respectively) Abcdxyzk wants to know the number of possible ways of the final result if the winner if m. (m = -1 for no winner of course) However, the answer maybe large, so abcdxyzk just want the remainder of the answer after divided by 1000000007.

            Input

            There are several test cases.

            For each case, only two integers n and m in a single line indicates n Candidates and the final winner m. (1 <= n <= 100, -1 <= m < n)

            Output

            For each test case, output the number of possible ways of the final election!

            Sample Input

            2 1
            3 -1
            4 1

            Sample Output

            1
            1
            4

            Hint

            In case 1, only one possible ways of the final result because both 0 and 1 vote to 1.

            In case 2, only one possible ways of the final result because all of 0, 1, and 2 get one vote.

            In case 3, there are 4 possible ways of final result:

            (1) 0: 1 (vote(s)) 1: 3 (vote(s)) 2: 0 (vote(s)) 3: 0 (vote(s))

            (2) 0: 0 (vote(s)) 1: 3 (vote(s)) 2: 1 (vote(s)) 3: 0 (vote(s))

            (3) 0: 0 (vote(s)) 1: 3 (vote(s)) 2: 0 (vote(s)) 3: 1 (vote(s))

            (4) 0: 0 (vote(s)) 1: 4 (vote(s)) 2: 0 (vote(s)) 3: 0 (vote(s))

            Source

            FOJ有獎月賽-2011年03月


            組合數。

            我的代碼:
             1 #include <stdio.h>
             2 
             3 typedef  long  long  Lint;
             4 
             5 #define  L  203
             6 #define  MOD  1000000007
             7 
             8 int c[ L ][ L ];
             9 
            10 int main() {
            11         int n, m, i, j, ans;
            12         for ( i = 0; i < L; ++i ) {
            13                 c[ i ][ 0 ] = c[ i ][ i ] = 1;
            14                 for ( j = 1; j < i; ++j ) {
            15                         c[ i ][ j ] = ( c[ i - 1 ][ j - 1 ] + c[ i - 1 ][ j ] ) % MOD;
            16                 }
            17         }
            18         while ( scanf( "%d%d"&n, &m ) == 2 ) {
            19                 if ( m < 0 ) {
            20                         ans = ( c[n+n-1][n] + (Lint)(MOD-c[(n-1)+(n-n/2-1)][n-1]) * n ) % MOD;
            21                 }
            22                 else {
            23                         ans = c[ (n-1+ (n-n/2-1) ][ n-1 ];
            24                 }
            25                 printf( "%d\n", ans );
            26         }
            27         return 0;
            28 }
            29 

            posted on 2011-03-23 22:46 coreBugZJ 閱讀(1462) 評論(0)  編輯 收藏 引用 所屬分類: ACM

            久久大香香蕉国产| 浪潮AV色综合久久天堂| 99久久免费只有精品国产| 久久精品国产网红主播| 久久久无码精品亚洲日韩按摩| 无码人妻少妇久久中文字幕蜜桃| 午夜天堂av天堂久久久| 色噜噜狠狠先锋影音久久| 性高湖久久久久久久久AAAAA| 人妻精品久久久久中文字幕69| 国产精品久久久久影院嫩草| 久久久久久久综合综合狠狠| 色8久久人人97超碰香蕉987| 久久91精品综合国产首页| 国产美女久久精品香蕉69| 伊人久久五月天| 久久国产精品免费一区二区三区 | 久久777国产线看观看精品| 久久久受www免费人成| 国产亚洲精品自在久久| 伊人色综合久久天天人守人婷| 1000部精品久久久久久久久| 四虎国产精品成人免费久久| 久久精品中文字幕一区| avtt天堂网久久精品| 99久久99久久精品国产片果冻 | 久久亚洲AV无码精品色午夜| 久久亚洲国产中v天仙www| 欧洲精品久久久av无码电影 | 久久精品国产精品亚洲人人| 狼狼综合久久久久综合网| 久久国语露脸国产精品电影| 久久婷婷五月综合97色直播| 成人亚洲欧美久久久久| 国产精品一区二区久久国产| 久久丫精品国产亚洲av| 人妻少妇久久中文字幕一区二区| 综合网日日天干夜夜久久| 国内精品久久国产| 久久无码中文字幕东京热| 亚洲午夜久久久影院伊人|