• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            coreBugZJ

            此 blog 已棄。

            HDOJ 3714 Error Curves

            Error Curves

            Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
            Total Submission(s): 275    Accepted Submission(s): 98


            Problem Description
            Josephina is a clever girl and addicted to Machine Learning recently. She
            pays much attention to a method called Linear Discriminant Analysis, which
            has many interesting properties.
            In order to test the algorithm's efficiency, she collects many datasets.
            What's more, each data is divided into two parts: training data and test
            data. She gets the parameters of the model on training data and test the
            model on test data. To her surprise, she finds each dataset's test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0.



            It's very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function's minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1...n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it's too hard for her to solve this problem. As a super programmer, can you help her?
             


             

            Input
            The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.
             


             

            Output
            For each test case, output the answer in a line. Round to 4 digits after the decimal point.
             


             

            Sample Input
            2 1 2 0 0 2 2 0 0 2 -4 2
             


             

            Sample Output
            0.0000 0.5000



            三分法


            #include <stdio.h>

            #define  L  10009
            #define  EPS  (1e-10)

            int n, a[ L ], b[ L ], c[ L ];

            int main() {
                    
            int td, i;
                    
            double left, right, midL, midR, tmpL, tmpR, maxL, maxR;
                    scanf( 
            "%d"&td );
                    
            while ( td-- > 0 ) {
                            scanf( 
            "%d"&n );
                            
            for ( i = 0; i < n; ++i ) {
                                    scanf( 
            "%d%d%d", a+i, b+i, c+i );
                            }

                            left 
            = 0;
                            right 
            = 1000;
                            
            while ( right - left > EPS ) {
                                    midL 
            = ( right - left ) / 3 + left;
                                    midR 
            = ( right - midL ) / 2 + midL;
                                    maxL 
            = maxR = -1e300;
                                    
            for ( i = 0; i < n; ++i ) {
                                            tmpL 
            = ( a[ i ] * midL + b[ i ] ) * midL + c[ i ];
                                            tmpR 
            = ( a[ i ] * midR + b[ i ] ) * midR + c[ i ];
                                            
            if ( maxL < tmpL ) {
                                                    maxL 
            = tmpL;
                                            }

                                            
            if ( maxR < tmpR ) {
                                                    maxR 
            = tmpR;
                                            }

                                    }

                                    
            if ( maxL < maxR ) {
                                            right 
            = midR;
                                    }

                                    
            else {
                                            left 
            = midL;
                                    }

                            }

                            printf( 
            "%0.4lf\n", maxL );
                    }

                    
            return 0;
            }


            posted on 2011-03-17 23:15 coreBugZJ 閱讀(1099) 評論(0)  編輯 收藏 引用 所屬分類: ACM

            久久国产AVJUST麻豆| 久久久久国产精品| 亚洲一本综合久久| 日韩久久久久久中文人妻| 久久香综合精品久久伊人| 国产69精品久久久久APP下载| 国内精品久久久久久久涩爱| 狠狠色综合网站久久久久久久| 久久精品国产亚洲网站| 精品综合久久久久久97超人| www.久久热.com| 青青青伊人色综合久久| 国产精品嫩草影院久久| 四虎影视久久久免费| 国产精品久久久久久久久久影院| 久久亚洲sm情趣捆绑调教| 久久婷婷人人澡人人爽人人爱| 日韩影院久久| 亚洲国产日韩综合久久精品| 久久久久国产精品嫩草影院| 久久精品人人做人人妻人人玩| 四虎国产精品免费久久久| 欧美无乱码久久久免费午夜一区二区三区中文字幕 | 99久久99这里只有免费的精品| 午夜人妻久久久久久久久| 国产亚洲美女精品久久久久狼| 久久精品国产亚洲AV不卡| 久久久久高潮综合影院| 精品久久香蕉国产线看观看亚洲| AAA级久久久精品无码区| 久久人人爽人人爽人人片AV麻烦 | 精品熟女少妇a∨免费久久| 亚洲综合精品香蕉久久网97| 久久久久国产精品嫩草影院| 日日噜噜夜夜狠狠久久丁香五月| 伊人久久大香线焦综合四虎| 日日狠狠久久偷偷色综合免费 | 秋霞久久国产精品电影院| 香蕉久久久久久狠狠色| 久久久久国产一级毛片高清版| 久久综合色老色|