• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            coreBugZJ

            此 blog 已棄。

            The kth great number, The 36th ACM/ICPC Asia Regional Dalian Site —— Online Contest

            The kth great number

            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)

            Problem Description
            Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
             

            Input
            There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 
             

            Output
            The output consists of one integer representing the largest number of islands that all lie on one line. 
             

            Sample Input
            8 3
            I 1
            I 2
            I 3
            Q
            I 5
            Q
            I 4
            Q
             

            Sample Output
            1
            2
            3

            Hint
            Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).
             


            打個醬油。
            小根堆保存最多 K 個元素,對每次詢問輸出堆頂元素。



             1 #include <iostream>
             2 #include <cstdio>
             3 #include <algorithm>
             4 #include <queue>
             5 
             6 using namespace std;
             7 
             8 typedef  priority_queue< int, vector< int >, greater< int > >  Heap;
             9 
            10 int main() {
            11         Heap mh;
            12         int n, k, x;
            13         char cmd[ 3 ];
            14         while ( 2 == scanf( "%d%d"&n, &k ) ) {
            15                 while ( ! mh.empty() ) {
            16                         mh.pop();
            17                 }
            18                 while ( n-- > 0 ) {
            19                         scanf( "%s", cmd );
            20                         if ( 'I' == cmd[ 0 ] ) {
            21                                 scanf( "%d"&x );
            22                                 mh.push( x );
            23                                 while ( mh.size() > k ) {
            24                                         mh.pop();
            25                                 }
            26                         }
            27                         else {
            28                                 printf( "%d\n", mh.top() );
            29                         }
            30                 }
            31         }
            32         return 0;
            33 }
            34 

            posted on 2011-09-03 18:17 coreBugZJ 閱讀(362) 評論(0)  編輯 收藏 引用 所屬分類: ACM

            99久久人人爽亚洲精品美女| 欧美久久天天综合香蕉伊| 亚洲?V乱码久久精品蜜桃| 久久久91人妻无码精品蜜桃HD | 国产成人精品免费久久久久| 国产精品久久久久久福利69堂| 久久99热国产这有精品| 久久AV高潮AV无码AV| 狠色狠色狠狠色综合久久| 久久国产视频网| 久久久久久九九99精品| 午夜精品久久久久| 国内精品久久久久久麻豆| 久久99精品国产99久久6男男| 久久久这里有精品中文字幕| 爱做久久久久久| 亚洲国产二区三区久久| 亚洲欧美伊人久久综合一区二区 | 国产精品免费久久久久久久久| 天天综合久久一二三区| 国产成人精品久久综合 | 欧美久久综合性欧美| 72种姿势欧美久久久久大黄蕉| 久久人妻少妇嫩草AV无码蜜桃| 国产欧美一区二区久久| 久久中文骚妇内射| 99精品久久精品| 亚洲综合精品香蕉久久网| 午夜欧美精品久久久久久久| 中文字幕久久亚洲一区| 亚洲AV无一区二区三区久久| 久久影院久久香蕉国产线看观看| 国产国产成人久久精品| 久久婷婷久久一区二区三区| AV狠狠色丁香婷婷综合久久 | 久久婷婷五月综合色奶水99啪| 久久成人永久免费播放| 色综合久久久久| 久久久久亚洲爆乳少妇无| 日批日出水久久亚洲精品tv| 久久天天躁狠狠躁夜夜2020老熟妇|