• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            coreBugZJ

            此 blog 已棄。

            Let it Bead,POJ 2409

            Let it Bead
            Time Limit: 1000MS
            Memory Limit: 65536K
            Total Submissions: 2318
            Accepted: 1448

            Description

            "Let it Bead" company is located upstairs at 700 Cannery Row in Monterey, CA. As you can deduce from the company name, their business is beads. Their PR department found out that customers are interested in buying colored bracelets. However, over 90 percent of the target audience insists that the bracelets be unique. (Just imagine what happened if two women showed up at the same party wearing identical bracelets!) It's a good thing that bracelets can have different lengths and need not be made of beads of one color. Help the boss estimating maximum profit by calculating how many different bracelets can be produced.

            A bracelet is a ring-like sequence of s beads each of which can have one of c distinct colors. The ring is closed, i.e. has no beginning or end, and has no direction. Assume an unlimited supply of beads of each color. For different values of s and c, calculate the number of different bracelets that can be made.

            Input

            Every line of the input file defines a test case and contains two integers: the number of available colors c followed by the length of the bracelets s. Input is terminated by c=s=0. Otherwise, both are positive, and, due to technical difficulties in the bracelet-fabrication-machine, cs<=32, i.e. their product does not exceed 32.

            Output

            For each test case output on a single line the number of unique bracelets. The figure below shows the 8 different bracelets that can be made with 2 colors and 5 beads.

            Sample Input

            1 1
            2 1
            2 2
            5 1
            2 5
            2 6
            6 2
            0 0

            Sample Output

            1
            2
            3
            5
            8
            13
            21

            Source

            Ulm Local 2000


            赤裸裸的 Polya,旋轉(zhuǎn) i 的循環(huán)個數(shù)為 gcd( i, n )


             1 #include <iostream>
             2 
             3 using namespace std;
             4 
             5 typedef long long Lint;
             6 
             7 Lint gcd( Lint a, Lint b ) {
             8         return ( (b==0? a : gcd(b,a%b) );
             9 }
            10 
            11 Lint power( Lint a, Lint b ) {
            12         Lint ans = 1;
            13         while ( b-- > 0 ) {
            14                 ans *= a;
            15         }
            16         return ans;
            17 }
            18 
            19 Lint solve( Lint n, Lint m ) {
            20         Lint i, ans = 0;
            21         for ( i = 1; i <= n; ++i ) {
            22                 ans += power( m, gcd(n,i) );
            23         }
            24         if ( n & 1 ) {
            25                 ans += n * power( m, n/2+1 );
            26         }
            27         else {
            28                 ans += power( m, n/2 ) * n / 2 + power( m, n/2+1 ) * n / 2;
            29         }
            30         ans /= n + n;
            31         return ans;
            32 }
            33 
            34 int main() {
            35         Lint n, m;
            36         for ( ; ; ) {
            37                 cin >> m >> n;
            38                 if ( (m<1&& (n<1) ) {
            39                         break;
            40                 }
            41                 cout << solve( n, m ) << "\n";
            42         }
            43         return 0;
            44 }
            45 


            posted on 2011-04-17 22:11 coreBugZJ 閱讀(439) 評論(0)  編輯 收藏 引用 所屬分類: ACM

            欧美久久久久久午夜精品| 精品熟女少妇av免费久久| 久久SE精品一区二区| 久久久久久久精品妇女99| 亚洲国产精品高清久久久| 成人妇女免费播放久久久| 久久精品国产半推半就| 久久午夜无码鲁丝片午夜精品| 久久人妻少妇嫩草AV无码蜜桃 | 国产一区二区三区久久| 久久性精品| 久久久精品一区二区三区| 一本色道久久HEZYO无码| 久久久久久毛片免费看| 精品久久久久香蕉网| 久久综合日本熟妇| 日本免费一区二区久久人人澡| 久久久国产精品| 狠狠久久亚洲欧美专区| 性色欲网站人妻丰满中文久久不卡| 99久久精品免费观看国产| 久久亚洲欧美国产精品| 无码人妻久久一区二区三区免费丨| 四虎国产永久免费久久| 九九久久99综合一区二区| 久久久亚洲欧洲日产国码aⅴ| 99久久99久久| 国产精品久久久福利| 欧美一区二区三区久久综合| 成人综合久久精品色婷婷| 中文字幕久久亚洲一区| 久久婷婷国产剧情内射白浆| 久久久噜噜噜久久中文字幕色伊伊| 国产精品欧美亚洲韩国日本久久| 久久国产精品99久久久久久老狼| 亚洲AV日韩AV永久无码久久| 亚洲国产视频久久| 波多野结衣久久| 一级a性色生活片久久无少妇一级婬片免费放 | 少妇久久久久久被弄高潮| 波多野结衣久久一区二区|