• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            POJ 2195 Going Home 二分圖完美匹配

            Description

            On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man.

            Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point.

            You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.

            Input

            There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.

            Output

            For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay.

            Sample Input

            2 2
            .m
            H.
            5 5
            HH..m
            .....
            .....
            .....
            mm..H
            7 8
            ...H....
            ...H....
            ...H....
            mmmHmmmm
            ...H....
            ...H....
            ...H....
            0 0
            

            Sample Output

            2
            10
            28
            

            Source


                題目大意:有m個人要進h間房子,從當前位置(x1,y1)進入房子(x2,y2)的時間為|x1-x2|+|y1-y2|,問這m個人都進入房間所需的最小時間是多少。問題可以轉化為帶權二分圖的最小權匹配,以sample 2為例先建立二分圖:
             
            (m1,h1)=4,(m1,h2)=3,(m1,h3)=4,(m2,h1)=4,(m2,h2)=5,(m2,h3)=4,(m3,h1)=5,(m3,h2)=4,(m3,h3)=3.
            然后用KM算法求解,代碼中的注釋部分為最大權匹配。
            #include <iostream>

            const int MAX = 101;
            const int MAXN = 10001;
            const int inf = 0x7FFFFFFF;
            struct point{
                
            int x,y;
            }
            man[MAXN],home[MAXN];
            bool vx[MAX],vy[MAX];
            int m,h,map[MAX][MAXN],lx[MAX],ly[MAX],match[MAX];

            bool dfs(int u){
                
            int i;
                
            for(vx[u]=true,i=0;i<h;i++)
                    
            if(!vy[i] && lx[u]+ly[i]==map[u][i]){
                        vy[i]
            =true;
                        
            if(match[i]==-1 || dfs(match[i])){
                            match[i]
            =u;
                            
            return true;
                        }

                    }

                
            return false;
            }

            int kuhn_munkras(){
                
            int i,j,k,min,ans;
                
            for(i=0;i<m;i++)
                    
            for(lx[i]=inf,j=0;j<h;j++)
                        
            if(map[i][j]<lx[i]) lx[i]=map[i][j];
              
            //for(i=0;i<m;i++)
              
            //    for(lx[i]=-inf,j=0;j<h;j++)
              
            //        if(map[i][j]>lx[i]) lx[i]=map[i][j]; 最大權匹配
                for(i=0;i<h;i++) ly[i]=0;
                memset(match,
            -1,sizeof(match));
                
            for(i=0;i<m;i++){
                    
            while(true){
                        memset(vx,
            false,sizeof(vx));
                        memset(vy,
            false,sizeof(vy));
                        min
            =inf;
                        
            if(dfs(i)) break;
                        
            for(j=0;j<m;j++){
                            
            if(vx[j]){
                                
            for(k=0;k<h;k++)
                                    
            if(!vy[k] && map[j][k]-lx[j]-ly[k]<min)
                                        min
            =map[j][k]-lx[j]-ly[k];
                                  
            //if(!vy[k] && lx[j]+ly[k]-map[j][k]<min)
                                  
            //    min=map[j][k]-lx[j]-ly[k]; 最大權匹配
                            }

                        }

                        
            for(j=0;j<m;j++if(vx[j]) lx[j]+=min;
                        
            for(j=0;j<h;j++if(vy[j]) ly[j]-=min;
                    }

                }

                
            for(ans=i=0;i<h;i++) ans+=map[match[i]][i];
                
            return ans;
            }

            int main(){
                
            char ch;
                
            int i,j,row,colum;
                
            while(scanf("%d %d",&row,&colum),row||colum){
                    
            for(getchar(),m=h=i=0;i<row;i++){
                        
            for(j=0;j<colum;j++){
                            ch
            =getchar();
                            
            if(ch=='m')
                                man[m].x
            =i,man[m].y=j,m++;
                            
            else if(ch=='H')
                                home[h].x
            =i,home[h].y=j,h++;
                        }

                        getchar();
                    }

                    memset(map,
            0,sizeof(map));
                    
            for(i=0;i<m;i++)
                        
            for(j=0;j<h;j++)
                            map[i][j]
            =abs(man[i].x-home[j].x)+abs(man[i].y-home[j].y);
                    printf(
            "%d\n",kuhn_munkras());
                }

                
            return 0;
            }

            posted on 2009-06-03 12:45 極限定律 閱讀(809) 評論(0)  編輯 收藏 引用 所屬分類: ACM/ICPC

            <2009年4月>
            2930311234
            567891011
            12131415161718
            19202122232425
            262728293012
            3456789

            導航

            統計

            常用鏈接

            留言簿(10)

            隨筆分類

            隨筆檔案

            友情鏈接

            搜索

            最新評論

            閱讀排行榜

            評論排行榜

            国产成人无码久久久精品一| 久久免费线看线看| 一极黄色视频久久网站| 人妻系列无码专区久久五月天| 久久综合亚洲色HEZYO国产| 亚州日韩精品专区久久久| 伊人色综合久久天天人守人婷 | 97热久久免费频精品99| 亚洲嫩草影院久久精品| 一级a性色生活片久久无少妇一级婬片免费放| 久久无码中文字幕东京热| 国产韩国精品一区二区三区久久| 国产精品99久久久久久猫咪| 亚洲中文字幕无码久久2020| 久久综合丝袜日本网| 综合久久国产九一剧情麻豆| 91久久福利国产成人精品| 欧美va久久久噜噜噜久久| 久久国产精品无码网站| 97久久久久人妻精品专区| 尹人香蕉久久99天天拍| 国产AV影片久久久久久| 久久综合狠狠综合久久综合88| 久久久国产精品| 久久99精品国产一区二区三区| 久久久久久精品久久久久| 久久综合九色综合久99| 91久久精品国产91性色也| 激情伊人五月天久久综合| 婷婷五月深深久久精品| 久久人妻少妇嫩草AV蜜桃| 国产A级毛片久久久精品毛片| 久久精品国产精品青草app| WWW婷婷AV久久久影片| 色综合久久久久久久久五月| 欧美日韩精品久久久久| 伊人久久大香线蕉精品不卡 | 97久久国产综合精品女不卡| 久久嫩草影院免费看夜色| 办公室久久精品| 国内精品久久久久影院网站|