• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            POJ 2195 Going Home 二分圖完美匹配

            Description

            On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man.

            Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point.

            You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.

            Input

            There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.

            Output

            For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay.

            Sample Input

            2 2
            .m
            H.
            5 5
            HH..m
            .....
            .....
            .....
            mm..H
            7 8
            ...H....
            ...H....
            ...H....
            mmmHmmmm
            ...H....
            ...H....
            ...H....
            0 0
            

            Sample Output

            2
            10
            28
            

            Source


                題目大意:有m個(gè)人要進(jìn)h間房子,從當(dāng)前位置(x1,y1)進(jìn)入房子(x2,y2)的時(shí)間為|x1-x2|+|y1-y2|,問(wèn)這m個(gè)人都進(jìn)入房間所需的最小時(shí)間是多少。問(wèn)題可以轉(zhuǎn)化為帶權(quán)二分圖的最小權(quán)匹配,以sample 2為例先建立二分圖:
             
            (m1,h1)=4,(m1,h2)=3,(m1,h3)=4,(m2,h1)=4,(m2,h2)=5,(m2,h3)=4,(m3,h1)=5,(m3,h2)=4,(m3,h3)=3.
            然后用KM算法求解,代碼中的注釋部分為最大權(quán)匹配。
            #include <iostream>

            const int MAX = 101;
            const int MAXN = 10001;
            const int inf = 0x7FFFFFFF;
            struct point{
                
            int x,y;
            }
            man[MAXN],home[MAXN];
            bool vx[MAX],vy[MAX];
            int m,h,map[MAX][MAXN],lx[MAX],ly[MAX],match[MAX];

            bool dfs(int u){
                
            int i;
                
            for(vx[u]=true,i=0;i<h;i++)
                    
            if(!vy[i] && lx[u]+ly[i]==map[u][i]){
                        vy[i]
            =true;
                        
            if(match[i]==-1 || dfs(match[i])){
                            match[i]
            =u;
                            
            return true;
                        }

                    }

                
            return false;
            }

            int kuhn_munkras(){
                
            int i,j,k,min,ans;
                
            for(i=0;i<m;i++)
                    
            for(lx[i]=inf,j=0;j<h;j++)
                        
            if(map[i][j]<lx[i]) lx[i]=map[i][j];
              
            //for(i=0;i<m;i++)
              
            //    for(lx[i]=-inf,j=0;j<h;j++)
              
            //        if(map[i][j]>lx[i]) lx[i]=map[i][j]; 最大權(quán)匹配
                for(i=0;i<h;i++) ly[i]=0;
                memset(match,
            -1,sizeof(match));
                
            for(i=0;i<m;i++){
                    
            while(true){
                        memset(vx,
            false,sizeof(vx));
                        memset(vy,
            false,sizeof(vy));
                        min
            =inf;
                        
            if(dfs(i)) break;
                        
            for(j=0;j<m;j++){
                            
            if(vx[j]){
                                
            for(k=0;k<h;k++)
                                    
            if(!vy[k] && map[j][k]-lx[j]-ly[k]<min)
                                        min
            =map[j][k]-lx[j]-ly[k];
                                  
            //if(!vy[k] && lx[j]+ly[k]-map[j][k]<min)
                                  
            //    min=map[j][k]-lx[j]-ly[k]; 最大權(quán)匹配
                            }

                        }

                        
            for(j=0;j<m;j++if(vx[j]) lx[j]+=min;
                        
            for(j=0;j<h;j++if(vy[j]) ly[j]-=min;
                    }

                }

                
            for(ans=i=0;i<h;i++) ans+=map[match[i]][i];
                
            return ans;
            }

            int main(){
                
            char ch;
                
            int i,j,row,colum;
                
            while(scanf("%d %d",&row,&colum),row||colum){
                    
            for(getchar(),m=h=i=0;i<row;i++){
                        
            for(j=0;j<colum;j++){
                            ch
            =getchar();
                            
            if(ch=='m')
                                man[m].x
            =i,man[m].y=j,m++;
                            
            else if(ch=='H')
                                home[h].x
            =i,home[h].y=j,h++;
                        }

                        getchar();
                    }

                    memset(map,
            0,sizeof(map));
                    
            for(i=0;i<m;i++)
                        
            for(j=0;j<h;j++)
                            map[i][j]
            =abs(man[i].x-home[j].x)+abs(man[i].y-home[j].y);
                    printf(
            "%d\n",kuhn_munkras());
                }

                
            return 0;
            }

            posted on 2009-06-03 12:45 極限定律 閱讀(809) 評(píng)論(0)  編輯 收藏 引用 所屬分類: ACM/ICPC

            <2009年5月>
            262728293012
            3456789
            10111213141516
            17181920212223
            24252627282930
            31123456

            導(dǎo)航

            統(tǒng)計(jì)

            常用鏈接

            留言簿(10)

            隨筆分類

            隨筆檔案

            友情鏈接

            搜索

            最新評(píng)論

            閱讀排行榜

            評(píng)論排行榜

            777午夜精品久久av蜜臀| 激情综合色综合久久综合| 久久综合偷偷噜噜噜色| 久久精品国产99国产精品亚洲 | 久久精品无码一区二区app| 久久嫩草影院免费看夜色| 国产美女亚洲精品久久久综合| 亚洲中文字幕久久精品无码喷水| 69久久精品无码一区二区| 国产精品永久久久久久久久久 | 国产成人精品久久| 99久久99这里只有免费的精品| 久久久久国产| 久久免费精品一区二区| 综合久久国产九一剧情麻豆| 久久久九九有精品国产| 亚洲欧美日韩久久精品第一区| 国产精品gz久久久| 国内精品久久久久久久97牛牛| 久久久久亚洲爆乳少妇无| 国产精品久久久久久久久| 2020国产成人久久精品| 久久精品亚洲精品国产欧美| 国产精品福利一区二区久久| 波多野结衣久久一区二区| 久久精品视频91| 久久九九久精品国产| 久久精品国产亚洲沈樵| 国产精品美女久久久m| 无码精品久久久天天影视| 久久精品视频一| 久久婷婷色香五月综合激情| 欧美午夜A∨大片久久 | 久久久久人妻一区精品果冻| 色综合色天天久久婷婷基地| 欧洲人妻丰满av无码久久不卡| 婷婷国产天堂久久综合五月| 久久精品国产欧美日韩| 亚洲欧洲久久av| 三级三级久久三级久久| 久久人人爽人人爽人人av东京热 |