• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            POJ 2115 模線性方程 ax=b(mod n)

            Description

            A Compiler Mystery: We are given a C-language style for loop of type
            for (variable = A; variable != B; variable += C)
            
            statement;

            I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.

            Input

            The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop.

            The input is finished by a line containing four zeros.

            Output

            The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.

            Sample Input

            3 3 2 16
            3 7 2 16
            7 3 2 16
            3 4 2 16
            0 0 0 0
            

            Sample Output

            0
            2
            32766
            FOREVER

            Source


                推論1:方程ax=b(mod n)對于未知量x有解,當且僅當gcd(a,n) | b。
                推論2:方程ax=b(mod n)或者對模n有d個不同的解,其中d=gcd(a,n),或者無解。
                定理1:設d=gcd(a,n),假定對整數x和y滿足d=ax+by(比如用擴展Euclid算法求出的一組解)。如果d | b,則方程ax=b(mod n)有一個解x0滿足x0=x*(b/d) mod n 。特別的設e=x0+n,方程ax=b(mod n)的最小整數解x1=e mod (n/d),最大整數解x2=x1+(d-1)*(n/d)。
                定理2:假設方程ax=b(mod n)有解,且x0是方程的任意一個解,則該方程對模n恰有d個不同的解(d=gcd(a,n)),分別為:xi=x0+i*(n/d) mod n 。
                以上定理的具體證明見《算法導論》。
            #include <iostream>
            using namespace std;

            long long ext_gcd(long long a,long long b,long long &x,long long &y){
                
            long long t,ret;
                
            if(!b){
                    x
            =1,y=0;
                    
            return a;
                }

                ret
            =ext_gcd(b,a%b,x,y);
                t
            =x,x=y,y=t-a/b*y;
                
            return ret;
            }

            long long modular_linear(long long a,long long b,long long n){
                
            long long d,e,x,y;
                d
            =ext_gcd(a,n,x,y);
                
            if(b%d)
                    
            return -1;
                e
            =x*(b/d)%n+n;
                
            return e%(n/d);
            }

            int main(){
                
            long long d,a,b,c,k;
                
            while(scanf("%lld %lld %lld %lld",&a,&b,&c,&k),a||b||c||k){
                    d
            =modular_linear(c,b-a,1LL<<k);
                    
            if(d==-1)
                        puts(
            "FOREVER");
                    
            else
                        printf(
            "%lld\n",d);
                }

                
            return 0;
            }

            posted on 2009-06-12 19:24 極限定律 閱讀(2659) 評論(0)  編輯 收藏 引用 所屬分類: ACM/ICPC

            <2015年9月>
            303112345
            6789101112
            13141516171819
            20212223242526
            27282930123
            45678910

            導航

            統計

            常用鏈接

            留言簿(10)

            隨筆分類

            隨筆檔案

            友情鏈接

            搜索

            最新評論

            閱讀排行榜

            評論排行榜

            国内精品久久久久| 中文字幕无码久久久| 人妻精品久久久久中文字幕69| 欧美激情一区二区久久久| 久久久这里只有精品加勒比| 婷婷久久香蕉五月综合加勒比| 狠狠色婷婷综合天天久久丁香 | 伊人久久大香线蕉综合Av| 久久精品国产亚洲AV麻豆网站 | 久久精品国产99国产精品导航 | 久久综合狠狠综合久久| 免费精品99久久国产综合精品| 欧美国产成人久久精品| 精品久久久久中文字幕日本| 久久er国产精品免费观看8| 亚洲欧洲日产国码无码久久99| 精品亚洲综合久久中文字幕| 午夜精品久久久久9999高清| 999久久久免费精品国产| 国产成人综合久久精品红| 亚洲欧美精品伊人久久| 久久夜色精品国产欧美乱| 人妻系列无码专区久久五月天| 狠狠色丁香久久婷婷综合五月| 无码精品久久一区二区三区| 99久久国产热无码精品免费久久久久| 欧美日韩精品久久久久| 日日狠狠久久偷偷色综合0| 青青青国产精品国产精品久久久久| 亚洲AV日韩AV永久无码久久| 久久久久久国产a免费观看黄色大片| 精品一久久香蕉国产线看播放| 久久天堂AV综合合色蜜桃网| 国产亚洲精久久久久久无码77777| 国内精品伊人久久久久影院对白| 狠狠色婷婷综合天天久久丁香 | 亚洲色欲久久久久综合网| 国产香蕉97碰碰久久人人| 国产亚洲色婷婷久久99精品91| 久久本道伊人久久| 亚洲国产成人久久精品影视|