• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            POJ 1157 LITTLE SHOP OF FLOWERS 動(dòng)態(tài)規(guī)劃

            Description

            You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers.

            Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has an aesthetic value of 0.
             

            V A S E S

            1

            2

            3

            4

            5

            Bunches

            1 (azaleas)

            7 23 -5 -24 16

            2 (begonias)

            5 21 -4 10 23

            3 (carnations)

            -21

            5 -4 -20 20

            According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4.

            To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have to produce exactly one arrangement.

            Input

            • The first line contains two numbers: F, V.
            • The following F lines: Each of these lines contains V integers, so that Aij is given as the jth number on the (i+1)st line of the input file.


            • 1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F.
            • F <= V <= 100 where V is the number of vases.
            • -50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j.

            Output

            The first line will contain the sum of aesthetic values for your arrangement.

            Sample Input

            3 5
            7 23 -5 -24 16
            5 21 -4 10 23
            -21 5 -4 -20 20

            Sample Output

            53

            Source

                因?yàn)轭}目中規(guī)定若i<j,則第i束花必須出現(xiàn)在第j束花之前,根據(jù)這一條件,可以用花的數(shù)目來進(jìn)行動(dòng)態(tài)規(guī)劃。設(shè)dp[i,j]為前i束花插在前j個(gè)花瓶中的最大美學(xué)值,有狀態(tài)轉(zhuǎn)移方程:dp[i,j]=max(dp[i-1,k-1]+A[i,k]),其中i<=k<=j,A[i,k]為第i束花插在第k個(gè)花瓶中的美學(xué)值,規(guī)定dp[i,0]=0,1<=i<=F。
            #include<iostream>
            using namespace std;

            const int MAXN = 101;
            const int inf = 10000;
            int A[MAXN][MAXN],dp[MAXN][MAXN];

            int main(){
                
            int i,j,k,f,v,t;
                
            while(scanf("%d %d",&f,&v)!=EOF){
                    
            for(i=1;i<=f;i++){
                        dp[i][
            0]=0;
                        
            for(j=1;j<=v;j++){
                            scanf(
            "%d",&A[i][j]);
                            dp[i][j]
            =-1;
                        }

                    }

                    
            for(i=1;i<=f;i++)
                        
            for(j=1;j<=v;j++)
                            
            for(t=-inf,k=i;k<=j;k++){
                                t
            =max(t,dp[i-1][k-1]+A[i][k]);
                                
            if(dp[i][j]==-1 || dp[i][j]<t)
                                    dp[i][j]
            =t;
                            }

                    printf(
            "%d\n",dp[f][v]);
                }

                
            return 0;
            }

            posted on 2009-06-16 13:57 極限定律 閱讀(1448) 評(píng)論(1)  編輯 收藏 引用 所屬分類: ACM/ICPC

            評(píng)論

            # re: POJ 1157 LITTLE SHOP OF FLOWERS 動(dòng)態(tài)規(guī)劃 2009-11-17 21:57 Gamor

            dp[i][j] = max(dp[i][j - 1], dp[i - 1][j - 1] + A[i][j])  回復(fù)  更多評(píng)論   

            <2025年5月>
            27282930123
            45678910
            11121314151617
            18192021222324
            25262728293031
            1234567

            導(dǎo)航

            統(tǒng)計(jì)

            常用鏈接

            留言簿(10)

            隨筆分類

            隨筆檔案

            友情鏈接

            搜索

            最新評(píng)論

            閱讀排行榜

            評(píng)論排行榜

            久久精品国产只有精品66| 久久久久久亚洲精品无码| 狼狼综合久久久久综合网| 久久国产免费观看精品3| 久久精品国产精品亚洲精品| 国产精品免费久久| 99久久做夜夜爱天天做精品| 性欧美丰满熟妇XXXX性久久久 | 久久亚洲AV无码西西人体| 亚洲七七久久精品中文国产 | 久久久久久久91精品免费观看| 青青草原精品99久久精品66| 国产精品伊人久久伊人电影| 7777精品久久久大香线蕉| 九九热久久免费视频| 新狼窝色AV性久久久久久| 久久性生大片免费观看性| 久久99国产综合精品女同| 亚洲乱码日产精品a级毛片久久| 99久久无色码中文字幕人妻| 欧美久久综合九色综合| 国产成人精品白浆久久69| 精品久久久久久国产| 久久高清一级毛片| 国产免费福利体检区久久| 久久亚洲综合色一区二区三区| 亚洲日本久久久午夜精品| 国内精品久久久久影院网站| 丁香狠狠色婷婷久久综合| 7777精品久久久大香线蕉| 久久人妻少妇嫩草AV蜜桃| 久久久久无码精品| 无码任你躁久久久久久久| 亚洲色欲久久久久综合网| 久久久久国产精品麻豆AR影院 | 久久久久国产精品三级网| 亚洲国产精久久久久久久| 免费精品99久久国产综合精品| 国产成人精品久久一区二区三区| 国产V综合V亚洲欧美久久| 久久精品国产亚洲综合色 |