• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            HDOJ 1016 Prime Ring Problem

            Problem Description
            A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

            Note: the number of first circle should always be 1.


             

            Input
            n (0 < n < 20).
             

            Output
            The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

            You are to write a program that completes above process.

            Print a blank line after each case.
             

            Sample Input
            6
            8
             

            Sample Output
            Case 1:
            1 4 3 2 5 6
            1 6 5 2 3 4
            Case 2:
            1 2 3 8 5 6 7 4
            1 2 5 8 3 4 7 6
            1 4 7 6 5 8 3 2
            1 6 7 4 3 8 5 2
                素數環:由1到n個數構成一個環,其中環內任意2個相鄰的數字之和是素數。
                比較經典的搜索題,由于n<20,可以先預處理出前40個自然數中的素數,然后深搜某個位置的未被訪問過的數字和它相鄰位置的數字之和是否為素數,搜索退出的條件為最后一個位置的數字circle[n]+1是否為素數。一次搜索完成后,要回溯,否則只會輸出一組解。
            #include <iostream>
            using namespace std;

            const int MAXN = 41;
            bool visit[MAXN];
            int n,p[MAXN],circle[MAXN];

            void prime(){
                
            int i,j;
                memset(p,
            true,sizeof(p));
                
            for(i=2;i<MAXN;i++)
                    
            for(j=2;i*j<MAXN;j++)
                        p[i
            *j]=false;
            }

            void dfs(int c,int cnt){
                
            if(cnt==&& p[circle[1]+circle[n]]){
                    
            for(int i=1;i<n;i++)
                        printf(
            "%d ",circle[i]);
                    printf(
            "%d\n",circle[n]);
                }

                
            for(int i=c+1;i<MAXN;i++)
                    
            if(p[i] && i-c<=&& !visit[i-c]){
                        circle[cnt
            +1]=i-c;
                        visit[i
            -c]=true;
                        dfs(i
            -c,cnt+1);
                        visit[i
            -c]=false;
                    }

            }

            int main(){
                
            int c=1;
                prime();
                
            while(scanf("%d",&n)!=EOF){
                    memset(visit,
            false,sizeof(visit));
                    printf(
            "Case %d:\n",c++);
                    visit[
            1]=true,circle[1]=1;
                    dfs(
            1,1);
                    printf(
            "\n");
                }

                
            return 0;
            }

            posted on 2009-05-24 13:37 極限定律 閱讀(1171) 評論(1)  編輯 收藏 引用 所屬分類: ACM/ICPC

            評論

            # re: HDOJ 1016 Prime Ring Problem 2009-08-04 09:53

            謝了 !!!!!!!!!!1  回復  更多評論   

            <2009年6月>
            31123456
            78910111213
            14151617181920
            21222324252627
            2829301234
            567891011

            導航

            統計

            常用鏈接

            留言簿(10)

            隨筆分類

            隨筆檔案

            友情鏈接

            搜索

            最新評論

            閱讀排行榜

            評論排行榜

            久久精品国产精品亚洲| 99精品国产免费久久久久久下载 | 久久久一本精品99久久精品88| 性做久久久久久免费观看| 97精品依人久久久大香线蕉97| 久久成人国产精品| 精品国产91久久久久久久a| 狠狠色婷婷久久综合频道日韩| 久久免费的精品国产V∧| 国产综合成人久久大片91| 久久亚洲精品无码aⅴ大香| 国产叼嘿久久精品久久| 成人妇女免费播放久久久| 91麻豆国产精品91久久久| 国产精品福利一区二区久久| 久久久无码精品亚洲日韩京东传媒| 欧美熟妇另类久久久久久不卡| 久久久久久曰本AV免费免费| 国产一级做a爰片久久毛片| 久久久无码人妻精品无码| 一本综合久久国产二区| 久久久久亚洲?V成人无码| 久久人妻少妇嫩草AV蜜桃| 国产成人香蕉久久久久| 一本久久a久久精品综合夜夜 | 亚洲色欲久久久综合网东京热| 伊人久久免费视频| 久久国产精品-国产精品| 久久久久国产精品熟女影院| 久久久久高潮综合影院| 国产精品99久久久久久宅男小说| 久久性精品| 综合久久久久久中文字幕亚洲国产国产综合一区首 | 久久精品人妻中文系列| 伊人久久大香线蕉综合网站| 国产精品成人99久久久久| 久久综合综合久久97色| 亚洲精品国产自在久久| 亚洲色欲久久久久综合网| 国产欧美久久久精品影院| 久久乐国产综合亚洲精品|