• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            POJ 2115 模線性方程 ax=b(mod n)

            Description

            A Compiler Mystery: We are given a C-language style for loop of type
            for (variable = A; variable != B; variable += C)
            
            statement;

            I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.

            Input

            The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop.

            The input is finished by a line containing four zeros.

            Output

            The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.

            Sample Input

            3 3 2 16
            3 7 2 16
            7 3 2 16
            3 4 2 16
            0 0 0 0
            

            Sample Output

            0
            2
            32766
            FOREVER

            Source


                推論1:方程ax=b(mod n)對于未知量x有解,當(dāng)且僅當(dāng)gcd(a,n) | b。
                推論2:方程ax=b(mod n)或者對模n有d個不同的解,其中d=gcd(a,n),或者無解。
                定理1:設(shè)d=gcd(a,n),假定對整數(shù)x和y滿足d=ax+by(比如用擴(kuò)展Euclid算法求出的一組解)。如果d | b,則方程ax=b(mod n)有一個解x0滿足x0=x*(b/d) mod n 。特別的設(shè)e=x0+n,方程ax=b(mod n)的最小整數(shù)解x1=e mod (n/d),最大整數(shù)解x2=x1+(d-1)*(n/d)。
                定理2:假設(shè)方程ax=b(mod n)有解,且x0是方程的任意一個解,則該方程對模n恰有d個不同的解(d=gcd(a,n)),分別為:xi=x0+i*(n/d) mod n 。
                以上定理的具體證明見《算法導(dǎo)論》。
            #include <iostream>
            using namespace std;

            long long ext_gcd(long long a,long long b,long long &x,long long &y){
                
            long long t,ret;
                
            if(!b){
                    x
            =1,y=0;
                    
            return a;
                }

                ret
            =ext_gcd(b,a%b,x,y);
                t
            =x,x=y,y=t-a/b*y;
                
            return ret;
            }

            long long modular_linear(long long a,long long b,long long n){
                
            long long d,e,x,y;
                d
            =ext_gcd(a,n,x,y);
                
            if(b%d)
                    
            return -1;
                e
            =x*(b/d)%n+n;
                
            return e%(n/d);
            }

            int main(){
                
            long long d,a,b,c,k;
                
            while(scanf("%lld %lld %lld %lld",&a,&b,&c,&k),a||b||c||k){
                    d
            =modular_linear(c,b-a,1LL<<k);
                    
            if(d==-1)
                        puts(
            "FOREVER");
                    
            else
                        printf(
            "%lld\n",d);
                }

                
            return 0;
            }

            posted on 2009-06-12 19:24 極限定律 閱讀(2662) 評論(0)  編輯 收藏 引用 所屬分類: ACM/ICPC

            <2009年6月>
            31123456
            78910111213
            14151617181920
            21222324252627
            2829301234
            567891011

            導(dǎo)航

            統(tǒng)計

            常用鏈接

            留言簿(10)

            隨筆分類

            隨筆檔案

            友情鏈接

            搜索

            最新評論

            閱讀排行榜

            評論排行榜

            亚洲午夜久久久影院| 99久久精品国内| 伊人久久亚洲综合影院| 99精品国产综合久久久久五月天| 亚洲AV无码久久精品成人 | 久久精品视频一| 人妻无码中文久久久久专区| 久久精品国产91久久综合麻豆自制 | AV无码久久久久不卡网站下载| 久久久久久久综合日本亚洲| 国产精品乱码久久久久久软件| 久久99精品久久久久久| 囯产极品美女高潮无套久久久| 97久久精品人人澡人人爽| 久久久无码精品亚洲日韩按摩| 久久久久亚洲AV成人网| 丁香狠狠色婷婷久久综合| 亚洲国产精品综合久久一线| 国内精品伊人久久久久av一坑| 久久青青草视频| 999久久久免费国产精品播放| 久久久久久亚洲精品成人| 欧美日韩精品久久久免费观看| 精品国产青草久久久久福利| 久久久精品2019免费观看| 亚洲AV日韩精品久久久久| 亚洲国产精品无码久久青草| 久久久久亚洲AV成人网| 精品久久久久久无码国产| 九九99精品久久久久久| 久久亚洲欧美国产精品| 日本人妻丰满熟妇久久久久久| 囯产精品久久久久久久久蜜桃| 久久亚洲AV无码精品色午夜麻豆| 四虎亚洲国产成人久久精品| 久久久久亚洲精品男人的天堂 | 精品国产日韩久久亚洲| 一本色综合久久| 无码日韩人妻精品久久蜜桃| 久久综合给合久久狠狠狠97色69| 久久国产欧美日韩精品|