• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            POJ 3692 Kindergarten 二分圖最大獨立集

            Description

            In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

            Input

            The input consists of multiple test cases. Each test case starts with a line containing three integers
            G, B (1 ≤ G, B ≤ 200) and M (0 ≤ MG × B), which is the number of girls, the number of boys and
            the number of pairs of girl and boy who know each other, respectively.
            Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
            The girls are numbered from 1 to G and the boys are numbered from 1 to B.

            The last test case is followed by a line containing three zeros.

            Output

            For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

            Sample Input

            2 3 3
            1 1
            1 2
            2 3
            2 3 5
            1 1
            1 2
            2 1
            2 2
            2 3
            0 0 0

            Sample Output

            Case 1: 3
            Case 2: 4

            Source


                 

            本題是要求圖中的最大完全子圖(最大團)中頂點的個數。由于原圖的補圖是一個二分圖,其最大完全數等價于其補圖的最大獨立集中元素的個數,于是可以根據二分圖的性質求出這個最大獨立集。而普通圖的最大團則是一個NP問題。

            定理:二分圖最大獨立集=頂點數-二分圖最大匹配

            最大完全數:圖中最大完全子圖的頂點個數。

            獨立集:圖中任意兩個頂點都不相連的頂點集合。

            #include <iostream>
            using namespace std;

            const int MAXN = 201;
            bool visit[MAXN];
            int n,m,k,mark[MAXN];
            bool map[MAXN][MAXN];

            bool dfs(int u){
                
            int i;
                
            for(i=1;i<=m;i++)
                    
            if(map[u][i] && !visit[i]){
                        visit[i]
            =true;
                        
            if(mark[i]==-1 || dfs(mark[i])){
                            mark[i]
            =u;
                            
            return true;
                        }

                    }

                
            return false;
            }

            int hungary(){
                
            int i,ans=0;
                
            for(i=1;i<=n;i++){
                    memset(visit,
            false,sizeof(visit));
                    
            if(dfs(i)) ans++;
                }

                
            return ans;
            }

            int main(){
                
            int i,j,x,y,id=1;
                
            while(scanf("%d %d %d",&n,&m,&k),n||m||k){
                    
            for(i=1;i<=n;i++for(j=1;j<=m;j++) map[i][j]=true;
                    
            while(k--){
                        scanf(
            "%d %d",&x,&y);
                        map[x][y]
            =false;
                    }

                    memset(mark,
            -1,sizeof(mark));
                    printf(
            "Case %d: %d\n",id++,n+m-hungary());
                }

                
            return 0;
            }

            posted on 2009-06-02 15:14 極限定律 閱讀(2073) 評論(0)  編輯 收藏 引用 所屬分類: ACM/ICPC

            <2009年8月>
            2627282930311
            2345678
            9101112131415
            16171819202122
            23242526272829
            303112345

            導航

            統計

            常用鏈接

            留言簿(10)

            隨筆分類

            隨筆檔案

            友情鏈接

            搜索

            最新評論

            閱讀排行榜

            評論排行榜

            久久成人小视频| 久久这里只有精品18| 国产精品99久久久久久www| 久久精品国产69国产精品亚洲| 久久精品国产一区| 久久综合一区二区无码| 亚洲色大成网站WWW久久九九| 精品久久人妻av中文字幕| 青青青青久久精品国产h久久精品五福影院1421 | 狠狠色丁香久久婷婷综| 国产真实乱对白精彩久久| 午夜久久久久久禁播电影| 久久久久国产精品麻豆AR影院| 久久精品无码一区二区app| 久久久久久久久久久免费精品| 韩国免费A级毛片久久| 四虎久久影院| 国产真实乱对白精彩久久| 精品国产一区二区三区久久| 一本色道久久综合狠狠躁篇| 草草久久久无码国产专区| 国产A级毛片久久久精品毛片| 国产精品无码久久久久| 成人久久精品一区二区三区| 亚洲人成无码久久电影网站| 国产精品免费久久久久影院| 国产亚洲色婷婷久久99精品| 国产精品99久久久精品无码| 欧美久久亚洲精品| 久久国产精品偷99| 久久99精品久久久久久不卡| 日本久久久精品中文字幕| 996久久国产精品线观看| 久久久久成人精品无码中文字幕| 久久国语露脸国产精品电影| 久久亚洲AV成人无码软件| 久久婷婷五月综合97色直播| 国产精品久久久久久久app | 午夜精品久久久久久久| 亚洲国产精品久久久天堂| 色欲综合久久中文字幕网|