Posted on 2010-08-07 18:08
MiYu 閱讀(838)
評論(0) 編輯 收藏 引用 所屬分類:
ACM ( 水題 ) 、
ACM ( 雜題 )
MiYu原創, 轉帖請注明 : 轉載自 ______________白白の屋
題目地址:
http://acm.hdu.edu.cn/showproblem.php?pid=2088
題目描述:
Problem Description
Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. “Look, I've built a wall!”, he tells his older sister Alice. “Nah, you should make all stacks the same height. Then you would have a real wall.”, she retorts. After a little consideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?
Input
The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1≤n≤50 and 1≤hi≤100.
The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.
The input is terminated by a set starting with n = 0. This set should not be processed.
Output
For each set, print the minimum number of bricks that have to be moved in order to make all the stacks the same height.
Output a blank line between each set.
Sample Input
6
5 2 4 1 7 5
0
Sample Output
5
題目分析:
哈哈 ,又是一個水題, 貌似這段時間一直在水題. 剛開始看的時候還以為是 DP , 看懂題目后知道這只是一個簡單的小學數學題,呵呵. 如果求移動步數還復雜點, 但題目要求的是 最小搬動次數, 那么只要求出平均值, 大于平均值的墻就是要移動的墻 ,累加就可以了.
代碼如下:
MiYu原創, 轉帖請注明 : 轉載自 ______________白白の屋
#include <iostream>
#include <string>
using namespace std;
int main ()
{
int N;
int f = 0;
while ( cin >> N, N )
{
if ( f )
{
cout << endl;
}
f = 1;
int num[N+1];
num[N] = 0;
for ( int i = 0; i != N; ++ i )
{
cin >> num[i];
num[N] += num[i];
}
num[N] /= N;
int nCount = 0;
for ( int i = 0; i != N; ++ i )
{
if ( num[i] > num[N] )
{
nCount += num[i] - num[N];
}
}
cout << nCount << endl;
}
return 0;
}