• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 3,  comments - 1,  trackbacks - 0
            學會了隊列.這道題的主要思想:

            5先入列   把5出列  5 可以變成 4 ,6 , 10, ,把得到的數入列,然后再出列分別處理..如果前面出現過就不入列..定義一個計數數組,然后number[y - 1] = number[y] + 1;  number[y + 1] = number[y] + 1; number[y * 2] = number[y] + 1;

            Catch That Cow
            Time Limit: 2000MS Memory Limit: 65536K
            Total Submissions: 8341 Accepted: 2476

            Description

            Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

            * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
            * Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

            If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

            Input

            Line 1: Two space-separated integers: N and K

            Output

            Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

            Sample Input

            5 17

            Sample Output

            4

            Hint

            The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.




            Source Code

            Problem: 3278 User: luoguangyao
            Memory: 1048K Time: 110MS
            Language: C++ Result: Accepted
            • Source Code
              #include <iostream>
                  #include <queue>
                  using namespace::std;
                  int number[100001] = {0};
                  bool num[100001] = {0};
                  int main()
                  {
                  queue<int> x;
                  int a;
                  int b;
                  scanf("%d%d",&a,&b);
                  int count = 0;
                  number[a] = 0;
                  x.push(a);
                  while (x.size())
                  {
                  int y = x.front();
                  x.pop();
                  num[y] = 1;
                  if (y == b)
                  {
                  break;
                  }
                  else
                  {
                  if (y - 1 >= 0)
                  {
                  if (!num[y - 1])
                  {
                  x.push(y - 1);
                  number[y - 1] = number[y] + 1;
                  num[y - 1] = 1;
                  }
                  }
                  if (y + 1 <= 100000)
                  {
                  if (!num[y + 1])
                  {
                  x.push(y + 1);
                  number[y + 1] = number[y] + 1;
                  num[y + 1] = 1;
                  }
                  }
                  if (y * 2 <= 100000)
                  {
                  if (!num[y * 2])
                  {
                  x.push(y * 2);
                  number[y * 2] = number[y] + 1;
                  num[y * 2] = 1;
                  }
                  }
                  }
                  }
                  cout << number[b] << endl;
                  return 0;
                  }
            posted on 2009-03-07 18:33 生活要低調 閱讀(1799) 評論(0)  編輯 收藏 引用
            <2025年5月>
            27282930123
            45678910
            11121314151617
            18192021222324
            25262728293031
            1234567

            常用鏈接

            留言簿(1)

            隨筆檔案

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

            久久亚洲精品无码播放| 蜜臀久久99精品久久久久久小说| 久久精品一区二区| 久久97久久97精品免视看| 亚洲AV伊人久久青青草原| 久久九九精品99国产精品| 青青青青久久精品国产| 久久综合视频网| 久久综合狠狠综合久久激情 | 无码精品久久一区二区三区 | 亚洲国产精品热久久| 欧美伊人久久大香线蕉综合69| 亚洲精品乱码久久久久久蜜桃不卡| 久久亚洲精精品中文字幕| 久久亚洲电影| 国产综合久久久久久鬼色| 久久www免费人成精品香蕉| 777午夜精品久久av蜜臀| 很黄很污的网站久久mimi色| 亚洲女久久久噜噜噜熟女| 国産精品久久久久久久| 久久久国产精品亚洲一区| 久久精品日日躁夜夜躁欧美| 日韩亚洲欧美久久久www综合网| 性做久久久久久久| 久久无码AV中文出轨人妻| 久久精品亚洲精品国产欧美| 国产精品久久国产精品99盘| 国产精品久久久久久久app| 欧美精品一区二区久久| 久久99精品国产麻豆蜜芽| 国产叼嘿久久精品久久| 青青青伊人色综合久久| 四虎国产精品免费久久久| 99re久久精品国产首页2020| 精品久久久久久成人AV| 粉嫩小泬无遮挡久久久久久| 久久99国产综合精品| 粉嫩小泬无遮挡久久久久久| 久久天天躁狠狠躁夜夜网站| 久久婷婷五月综合色高清|