• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 3,  comments - 1,  trackbacks - 0
            學會了隊列.這道題的主要思想:

            5先入列   把5出列  5 可以變成 4 ,6 , 10, ,把得到的數入列,然后再出列分別處理..如果前面出現過就不入列..定義一個計數數組,然后number[y - 1] = number[y] + 1;  number[y + 1] = number[y] + 1; number[y * 2] = number[y] + 1;

            Catch That Cow
            Time Limit: 2000MS Memory Limit: 65536K
            Total Submissions: 8341 Accepted: 2476

            Description

            Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

            * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
            * Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

            If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

            Input

            Line 1: Two space-separated integers: N and K

            Output

            Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

            Sample Input

            5 17

            Sample Output

            4

            Hint

            The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.




            Source Code

            Problem: 3278 User: luoguangyao
            Memory: 1048K Time: 110MS
            Language: C++ Result: Accepted
            • Source Code
              #include <iostream>
                  #include <queue>
                  using namespace::std;
                  int number[100001] = {0};
                  bool num[100001] = {0};
                  int main()
                  {
                  queue<int> x;
                  int a;
                  int b;
                  scanf("%d%d",&a,&b);
                  int count = 0;
                  number[a] = 0;
                  x.push(a);
                  while (x.size())
                  {
                  int y = x.front();
                  x.pop();
                  num[y] = 1;
                  if (y == b)
                  {
                  break;
                  }
                  else
                  {
                  if (y - 1 >= 0)
                  {
                  if (!num[y - 1])
                  {
                  x.push(y - 1);
                  number[y - 1] = number[y] + 1;
                  num[y - 1] = 1;
                  }
                  }
                  if (y + 1 <= 100000)
                  {
                  if (!num[y + 1])
                  {
                  x.push(y + 1);
                  number[y + 1] = number[y] + 1;
                  num[y + 1] = 1;
                  }
                  }
                  if (y * 2 <= 100000)
                  {
                  if (!num[y * 2])
                  {
                  x.push(y * 2);
                  number[y * 2] = number[y] + 1;
                  num[y * 2] = 1;
                  }
                  }
                  }
                  }
                  cout << number[b] << endl;
                  return 0;
                  }
            posted on 2009-03-07 18:33 生活要低調 閱讀(1801) 評論(0)  編輯 收藏 引用
            <2009年3月>
            22232425262728
            1234567
            891011121314
            15161718192021
            22232425262728
            2930311234

            常用鏈接

            留言簿(1)

            隨筆檔案

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

            久久精品国产久精国产一老狼| 久久久久四虎国产精品| 亚洲精品NV久久久久久久久久 | 久久婷婷五月综合97色直播| 亚洲国产成人精品91久久久 | 欧美性猛交xxxx免费看久久久 | 曰曰摸天天摸人人看久久久| 久久久久亚洲精品中文字幕 | 无码任你躁久久久久久久| 亚洲综合日韩久久成人AV| 99久久婷婷国产综合精品草原| 人妻无码久久精品| 久久99国产精品一区二区| 久久精品中文无码资源站| 久久精品中文字幕第23页| 久久91亚洲人成电影网站| 久久狠狠爱亚洲综合影院| 免费一级欧美大片久久网| 久久免费美女视频| .精品久久久麻豆国产精品| 亚洲精品久久久www| 国内精品久久久久久久涩爱| 国产精品毛片久久久久久久| 久久精品无码一区二区WWW| 久久亚洲av无码精品浪潮| 久久久久亚洲AV无码专区网站 | 久久久亚洲欧洲日产国码aⅴ| 久久青青国产| 久久免费视频6| 欧洲性大片xxxxx久久久| 久久乐国产精品亚洲综合| 国产免费福利体检区久久| 人人狠狠综合久久亚洲88| 国产精品久久国产精品99盘| 久久久久人妻一区精品色| 久久精品国产第一区二区三区| 青草国产精品久久久久久| 国内精品综合久久久40p| 综合人妻久久一区二区精品| 狠狠色婷婷久久综合频道日韩 | 伊人久久国产免费观看视频|