• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 3,  comments - 1,  trackbacks - 0
            學會了隊列.這道題的主要思想:

            5先入列   把5出列  5 可以變成 4 ,6 , 10, ,把得到的數入列,然后再出列分別處理..如果前面出現過就不入列..定義一個計數數組,然后number[y - 1] = number[y] + 1;  number[y + 1] = number[y] + 1; number[y * 2] = number[y] + 1;

            Catch That Cow
            Time Limit: 2000MS Memory Limit: 65536K
            Total Submissions: 8341 Accepted: 2476

            Description

            Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

            * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
            * Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

            If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

            Input

            Line 1: Two space-separated integers: N and K

            Output

            Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

            Sample Input

            5 17

            Sample Output

            4

            Hint

            The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.




            Source Code

            Problem: 3278 User: luoguangyao
            Memory: 1048K Time: 110MS
            Language: C++ Result: Accepted
            • Source Code
              #include <iostream>
                  #include <queue>
                  using namespace::std;
                  int number[100001] = {0};
                  bool num[100001] = {0};
                  int main()
                  {
                  queue<int> x;
                  int a;
                  int b;
                  scanf("%d%d",&a,&b);
                  int count = 0;
                  number[a] = 0;
                  x.push(a);
                  while (x.size())
                  {
                  int y = x.front();
                  x.pop();
                  num[y] = 1;
                  if (y == b)
                  {
                  break;
                  }
                  else
                  {
                  if (y - 1 >= 0)
                  {
                  if (!num[y - 1])
                  {
                  x.push(y - 1);
                  number[y - 1] = number[y] + 1;
                  num[y - 1] = 1;
                  }
                  }
                  if (y + 1 <= 100000)
                  {
                  if (!num[y + 1])
                  {
                  x.push(y + 1);
                  number[y + 1] = number[y] + 1;
                  num[y + 1] = 1;
                  }
                  }
                  if (y * 2 <= 100000)
                  {
                  if (!num[y * 2])
                  {
                  x.push(y * 2);
                  number[y * 2] = number[y] + 1;
                  num[y * 2] = 1;
                  }
                  }
                  }
                  }
                  cout << number[b] << endl;
                  return 0;
                  }
            posted on 2009-03-07 18:33 生活要低調 閱讀(1798) 評論(0)  編輯 收藏 引用
            <2025年5月>
            27282930123
            45678910
            11121314151617
            18192021222324
            25262728293031
            1234567

            常用鏈接

            留言簿(1)

            隨筆檔案

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

            久久无码一区二区三区少妇 | 日本免费久久久久久久网站| 99久久精品午夜一区二区| 久久国产精品99精品国产| 国产午夜福利精品久久| 精品国产乱码久久久久软件| 国产日产久久高清欧美一区| 午夜精品久久久久久影视777| 久久人爽人人爽人人片AV| 2021国产成人精品久久| 午夜不卡久久精品无码免费| 国产精品午夜久久| 日韩精品久久无码人妻中文字幕| 久久精品亚洲男人的天堂| 狠狠88综合久久久久综合网| 伊人久久一区二区三区无码| 久久综合久久久| 久久精品国产精品亚洲毛片| 久久久久国产精品嫩草影院| 久久人搡人人玩人妻精品首页| 久久精品中文字幕久久| 久久国产色AV免费观看| 久久精品国产日本波多野结衣| 久久99精品久久久久久齐齐| 99久久国产免费福利| 久久99精品久久久久久hb无码| 欧美伊人久久大香线蕉综合| 国产精品99久久久久久猫咪| 国产精品久久久久久搜索| 久久青青草原精品国产| 久久午夜伦鲁片免费无码| 香蕉久久av一区二区三区| 一97日本道伊人久久综合影院| 99热热久久这里只有精品68| 国产亚洲欧美成人久久片| 久久偷看各类wc女厕嘘嘘| 亚洲女久久久噜噜噜熟女| 日韩av无码久久精品免费| 亚洲精品乱码久久久久久| 无码人妻久久久一区二区三区| 久久偷看各类wc女厕嘘嘘|