• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            poj 2524 Ubiquitous Religions 【并查集】

            Ubiquitous Religions
            Time Limit: 5000MS Memory Limit: 65536K
            Total Submissions: 12445 Accepted: 5900

            Description

            There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

            You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

            Input

            The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

            Output

            For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

            Sample Input

            10 9
            1 2
            1 3
            1 4
            1 5
            1 6
            1 7
            1 8
            1 9
            1 10
            10 4
            2 3
            4 5
            4 8
            5 8
            0 0
            

            Sample Output

            Case 1: 1
            Case 2: 7
            第一個并查集程序,最小生成樹不算。
             n個點,給你m條邊,求最大能有多少個連通分量。
            #include<iostream>
            using namespace std;
            const int MAX=50001;
            int fa[MAX];

            int find(int x)
            {
                
            return fa[x]==x?x:find(fa[x]);
            }

            void Union(int x, int y)
            {
                 fa[find(x)]
            =find(y);
            }
            int main()
            {
                
            int n,m;
                
            for(int tt=1; ; tt++)
                { 
                          cin
            >>n>>m;
                         
            if( n==0&&m==0)break;
                         
                         
            for(int i=1; i<=n; i++)
                                 fa[i]
            =i; 
                                 
                         
            int max=n;              
                         
            for(int i=1,s,t; i<=m; i++)
                                 {
                                     cin
            >>s>>t;
                                     
            if(find(s)!=find(t))max=max-1;
                                     Union(s,t);              
                                 }
                                 
                         cout
            <<"Case "<<tt<<':'<<' '<<max<<endl;
                         
                }
                
                system(
            "pause");    
                
            return 0;
            }


            posted on 2010-08-26 19:20 田兵 閱讀(316) 評論(0)  編輯 收藏 引用 所屬分類: 算法筆記

            <2010年8月>
            25262728293031
            1234567
            891011121314
            15161718192021
            22232425262728
            2930311234

            導航

            統計

            常用鏈接

            留言簿(2)

            隨筆分類(65)

            隨筆檔案(65)

            文章檔案(2)

            ACM

            搜索

            積分與排名

            最新隨筆

            最新評論

            閱讀排行榜

            97久久国产亚洲精品超碰热 | 无码8090精品久久一区| 亚洲精品国产字幕久久不卡| 久久久久AV综合网成人| 久久综合久久综合九色| 久久亚洲色一区二区三区| 久久久久亚洲AV无码观看| 久久久无码一区二区三区| 久久精品国产精品亜洲毛片| 精品国产乱码久久久久软件| 日韩精品国产自在久久现线拍| 99久久综合国产精品免费| 久久精品国产99国产电影网| 亚洲&#228;v永久无码精品天堂久久| 亚洲中文字幕无码久久精品1| 国产精品热久久毛片| 婷婷久久久亚洲欧洲日产国码AV| 久久99久久成人免费播放| 久久婷婷成人综合色综合| 精品久久久久久国产| 四虎国产精品免费久久| 青青草国产精品久久| 久久国产亚洲精品无码| 亚洲天堂久久久| 精品水蜜桃久久久久久久| 久久发布国产伦子伦精品| 久久久无码精品亚洲日韩京东传媒| AA级片免费看视频久久| www.久久热| 久久成人精品视频| 蜜臀av性久久久久蜜臀aⅴ麻豆| 亚洲午夜无码AV毛片久久| 精品久久久无码中文字幕天天| 久久精品国产亚洲麻豆| 久久本道伊人久久| 国产精品免费久久| 精品国产乱码久久久久久浪潮| 成人国内精品久久久久影院VR| 国产精品美女久久久| 久久中文字幕一区二区| 一级做a爱片久久毛片|