• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            oyjpArt ACM/ICPC算法程序設(shè)計(jì)空間

            // I am new in programming, welcome to my blog
            I am oyjpart(alpc12, 四城)
            posts - 224, comments - 694, trackbacks - 0, articles - 6

            Organize Your Train part II
            Time Limit:1000MS? Memory Limit:65536K
            Total Submit:417 Accepted:211

            Description

            RJ Freight, a Japanese railroad company for freight operations has recently constructed exchange lines at Hazawa, Yokohama. The layout of the lines is shown in Figure 1.


            Figure 1: Layout of the exchange lines

            A freight train consists of 2 to 72 freight cars. There are 26 types of freight cars, which are denoted by 26 lowercase letters from "a" to "z". The cars of the same type are indistinguishable from each other, and each car's direction doesn't matter either. Thus, a string of lowercase letters of length 2 to 72 is sufficient to completely express the configuration of a train.

            Upon arrival at the exchange lines, a train is divided into two sub-trains at an arbitrary position (prior to entering the storage lines). Each of the sub-trains may have its direction reversed (using the reversal line). Finally, the two sub-trains are connected in either order to form the final configuration. Note that the reversal operation is optional for each of the sub-trains.

            For example, if the arrival configuration is "abcd", the train is split into two sub-trains of either 3:1, 2:2 or 1:3 cars. For each of the splitting, possible final configurations are as follows ("+" indicates final concatenation position):

              [3:1]
            
            abc+d cba+d d+abc d+cba
            [2:2]
            ab+cd ab+dc ba+cd ba+dc cd+ab cd+ba dc+ab dc+ba
            [1:3]
            a+bcd a+dcb bcd+a dcb+a

            Excluding duplicates, 12 distinct configurations are possible.

            Given an arrival configuration, answer the number of distinct configurations which can be constructed using the exchange lines described above.

            Input

            The entire input looks like the following.

            the number of datasets = m
            1st dataset
            2nd dataset
            ...
            m-th dataset

            Each dataset represents an arriving train, and is a string of 2 to 72 lowercase letters in an input line.

            Output

            For each dataset, output the number of possible train configurations in a line. No other characters should appear in the output.

            Sample Input

            4
            aa
            abba
            abcd
            abcde

            Sample Output

            1
            6
            12
            18





            真不好意思 最近生病了 好幾天才回復(fù)你的問(wèn)題
            題目不難 簡(jiǎn)單模擬一下就可以了
            但是我覺(jué)得直接做比較麻煩 推薦STL做吧
            直接做可以用strrev等函數(shù)減少代碼量


            Solution
            //by Optimistic
            #include <string>
            #include <iostream>
            #include <algorithm>
            #include <vector>
            #include <set>
            using namespace std;
            int main()
            {
            ?int ns;
            ?vector<string> vs;
            ?int i;
            ?scanf("%d", &ns);
            ?while(ns--)
            ?{
            ??vs.clear();
            ??string s;
            ??cin >> s;
            ??for(i=1; i<s.length(); i++)
            ??{
            ???string a = s.substr(0, i);
            ???string b = s.substr(i);
            ???vs.push_back(a+b);
            ???vs.push_back(b+a);
            ???string ra(a);
            ???string rb(b);
            ???reverse(ra.begin(), ra.end());
            ???reverse(rb.begin(), rb.end());
            ???vs.push_back(a+rb);
            ???vs.push_back(ra+b);
            ???vs.push_back(rb+a);
            ???vs.push_back(b+ra);
            ???vs.push_back(ra+rb);
            ???vs.push_back(rb+ra);
            ??}
            ??set<string> ss(vs.begin(), vs.end());
            ??cout << ss.size() << endl;
            ?}
            ?return 0;
            }
            ?

            Feedback

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II   回復(fù)  更多評(píng)論   

            2008-04-16 05:12 by arena_zp
            TLE 啊。。。=___= 555555

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II   回復(fù)  更多評(píng)論   

            2008-04-16 13:14 by oyjpart
            o ?
            你的做法是這樣的嗎

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II   回復(fù)  更多評(píng)論   

            2008-09-21 11:54 by tec
            我直接把你的代碼復(fù)制上去 tle了

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II [未登錄](méi)  回復(fù)  更多評(píng)論   

            2008-09-25 02:19 by oyjpart
            加數(shù)據(jù)了吧,你把string換成char[]吧

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II   回復(fù)  更多評(píng)論   

            2009-08-04 00:58 by schindlerlee
            別用set了,把這兩句
            set<string> ss(vs.begin(), vs.end());
            cout << ss.size() << endl;
            換成
            sort(vs.begin(), vs.end());
            vector<string>::iterator iter = unique(vs.begin(), vs.end());
            cout << iter - vs.begin() << endl;

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II   回復(fù)  更多評(píng)論   

            2009-09-07 23:59 by oyjpart
            搞acm非要在乎這個(gè)參數(shù)時(shí)間的話,不如不用stl,直接去重好了:)

            只有注冊(cè)用戶登錄后才能發(fā)表評(píng)論。
            網(wǎng)站導(dǎo)航: 博客園   IT新聞   BlogJava   博問(wèn)   Chat2DB   管理


            色综合久久综合中文综合网| 久久人妻少妇嫩草AV无码专区| 国产精品青草久久久久福利99| 国产精品成人无码久久久久久 | 久久久无码精品亚洲日韩京东传媒| 香蕉久久夜色精品国产尤物| 久久精品国产亚洲AV电影 | 久久久久免费视频| 亚洲乱码中文字幕久久孕妇黑人| 99久久免费国产特黄| 日韩欧美亚洲国产精品字幕久久久 | 久久婷婷五月综合色奶水99啪| 久久婷婷五月综合97色直播 | 久久99国产精品成人欧美| 精品久久久久久无码不卡| 国产精品福利一区二区久久| 一本大道久久香蕉成人网| 久久综合九色综合精品| 香蕉久久av一区二区三区| 久久天天日天天操综合伊人av| 国产精品对白刺激久久久| 久久亚洲国产精品成人AV秋霞| 国产精品青草久久久久福利99 | 蜜桃麻豆WWW久久囤产精品| 久久久久综合网久久| 色综合久久综合中文综合网| 热99RE久久精品这里都是精品免费| 精品综合久久久久久88小说| 99久久无码一区人妻a黑| 无码AV中文字幕久久专区| 亚洲中文字幕无码一久久区| 亚洲精品tv久久久久| 久久久精品久久久久久| 狠狠人妻久久久久久综合蜜桃| 99久久免费国产精精品| 99久久精品影院老鸭窝| 精品国产91久久久久久久| 国产精品一区二区久久国产| 亚洲香蕉网久久综合影视| 久久精品卫校国产小美女| 亚洲精品乱码久久久久久|