• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            oyjpArt ACM/ICPC算法程序設計空間

            // I am new in programming, welcome to my blog
            I am oyjpart(alpc12, 四城)
            posts - 224, comments - 694, trackbacks - 0, articles - 6

            Organize Your Train part II
            Time Limit:1000MS? Memory Limit:65536K
            Total Submit:417 Accepted:211

            Description

            RJ Freight, a Japanese railroad company for freight operations has recently constructed exchange lines at Hazawa, Yokohama. The layout of the lines is shown in Figure 1.


            Figure 1: Layout of the exchange lines

            A freight train consists of 2 to 72 freight cars. There are 26 types of freight cars, which are denoted by 26 lowercase letters from "a" to "z". The cars of the same type are indistinguishable from each other, and each car's direction doesn't matter either. Thus, a string of lowercase letters of length 2 to 72 is sufficient to completely express the configuration of a train.

            Upon arrival at the exchange lines, a train is divided into two sub-trains at an arbitrary position (prior to entering the storage lines). Each of the sub-trains may have its direction reversed (using the reversal line). Finally, the two sub-trains are connected in either order to form the final configuration. Note that the reversal operation is optional for each of the sub-trains.

            For example, if the arrival configuration is "abcd", the train is split into two sub-trains of either 3:1, 2:2 or 1:3 cars. For each of the splitting, possible final configurations are as follows ("+" indicates final concatenation position):

              [3:1]
            
            abc+d cba+d d+abc d+cba
            [2:2]
            ab+cd ab+dc ba+cd ba+dc cd+ab cd+ba dc+ab dc+ba
            [1:3]
            a+bcd a+dcb bcd+a dcb+a

            Excluding duplicates, 12 distinct configurations are possible.

            Given an arrival configuration, answer the number of distinct configurations which can be constructed using the exchange lines described above.

            Input

            The entire input looks like the following.

            the number of datasets = m
            1st dataset
            2nd dataset
            ...
            m-th dataset

            Each dataset represents an arriving train, and is a string of 2 to 72 lowercase letters in an input line.

            Output

            For each dataset, output the number of possible train configurations in a line. No other characters should appear in the output.

            Sample Input

            4
            aa
            abba
            abcd
            abcde

            Sample Output

            1
            6
            12
            18





            真不好意思 最近生病了 好幾天才回復你的問題
            題目不難 簡單模擬一下就可以了
            但是我覺得直接做比較麻煩 推薦STL做吧
            直接做可以用strrev等函數減少代碼量


            Solution
            //by Optimistic
            #include <string>
            #include <iostream>
            #include <algorithm>
            #include <vector>
            #include <set>
            using namespace std;
            int main()
            {
            ?int ns;
            ?vector<string> vs;
            ?int i;
            ?scanf("%d", &ns);
            ?while(ns--)
            ?{
            ??vs.clear();
            ??string s;
            ??cin >> s;
            ??for(i=1; i<s.length(); i++)
            ??{
            ???string a = s.substr(0, i);
            ???string b = s.substr(i);
            ???vs.push_back(a+b);
            ???vs.push_back(b+a);
            ???string ra(a);
            ???string rb(b);
            ???reverse(ra.begin(), ra.end());
            ???reverse(rb.begin(), rb.end());
            ???vs.push_back(a+rb);
            ???vs.push_back(ra+b);
            ???vs.push_back(rb+a);
            ???vs.push_back(b+ra);
            ???vs.push_back(ra+rb);
            ???vs.push_back(rb+ra);
            ??}
            ??set<string> ss(vs.begin(), vs.end());
            ??cout << ss.size() << endl;
            ?}
            ?return 0;
            }
            ?

            Feedback

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II   回復  更多評論   

            2008-04-16 05:12 by arena_zp
            TLE 啊。。。=___= 555555

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II   回復  更多評論   

            2008-04-16 13:14 by oyjpart
            o ?
            你的做法是這樣的嗎

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II   回復  更多評論   

            2008-09-21 11:54 by tec
            我直接把你的代碼復制上去 tle了

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II [未登錄]  回復  更多評論   

            2008-09-25 02:19 by oyjpart
            加數據了吧,你把string換成char[]吧

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II   回復  更多評論   

            2009-08-04 00:58 by schindlerlee
            別用set了,把這兩句
            set<string> ss(vs.begin(), vs.end());
            cout << ss.size() << endl;
            換成
            sort(vs.begin(), vs.end());
            vector<string>::iterator iter = unique(vs.begin(), vs.end());
            cout << iter - vs.begin() << endl;

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II   回復  更多評論   

            2009-09-07 23:59 by oyjpart
            搞acm非要在乎這個參數時間的話,不如不用stl,直接去重好了:)
            亚洲va国产va天堂va久久| 99精品国产99久久久久久97| 欧美牲交A欧牲交aⅴ久久| 久久精品亚洲AV久久久无码| 亚洲va中文字幕无码久久不卡| 亚洲国产另类久久久精品| 国产精品毛片久久久久久久| 国产亚洲精久久久久久无码AV| 久久精品中文字幕一区| 亚洲伊人久久精品影院| 伊人丁香狠狠色综合久久| 久久精品亚洲中文字幕无码麻豆| 久久亚洲精品无码AV红樱桃| 99久久精品免费看国产一区二区三区| 久久久久国产| 久久香蕉综合色一综合色88| 久久久久人妻一区二区三区 | 久久精品嫩草影院| 欧美成人免费观看久久| 久久99国产亚洲高清观看首页 | 99久久精品免费看国产| 色综合久久无码中文字幕| 午夜精品久久影院蜜桃| 久久精品国产99国产电影网| 久久精品国产2020| 伊人久久亚洲综合影院| 欧洲性大片xxxxx久久久| 久久精品国产秦先生| 亚洲精品无码久久久久久| 中文精品久久久久人妻| 伊人久久国产免费观看视频 | 成人午夜精品无码区久久| 久久久黄片| 精品一久久香蕉国产线看播放| 日本道色综合久久影院| 精品综合久久久久久97超人| AAA级久久久精品无码片| 婷婷综合久久中文字幕蜜桃三电影| 伊人伊成久久人综合网777| 久久综合久久鬼色| 亚洲人成无码网站久久99热国产 |