• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            oyjpArt ACM/ICPC算法程序設計空間

            // I am new in programming, welcome to my blog
            I am oyjpart(alpc12, 四城)
            posts - 224, comments - 694, trackbacks - 0, articles - 6

            PKU1925 Spiderman 【DP】

            Posted on 2007-04-05 20:41 oyjpart 閱讀(2323) 評論(2)  編輯 收藏 引用 所屬分類: ACM/ICPC或其他比賽

            Spiderman
            Time Limit:5000MS  Memory Limit:65536K
            Total Submit:1762 Accepted:197

            Description
            Dr. Octopus kidnapped Spiderman's girlfriend M.J. and kept her in the West Tower. Now the hero, Spiderman, has to reach the tower as soon as he can to rescue her, using his own weapon, the web.

            From Spiderman's apartment, where he starts, to the tower there is a straight road. Alongside of the road stand many tall buildings, which are definitely taller or equal to his apartment. Spiderman can shoot his web to the top of any building between the tower and himself (including the tower), and then swing to the other side of the building. At the moment he finishes the swing, he can shoot his web to another building and make another swing until he gets to the west tower. Figure-1 shows how Spiderman gets to the tower from the top of his apartment – he swings from A to B, from B to C, and from C to the tower. All the buildings (including the tower) are treated as straight lines, and during his swings he can't hit the ground, which means the length of the web is shorter or equal to the height of the building. Notice that during Spiderman's swings, he can never go backwards.


            You may assume that each swing takes a unit of time. As in Figure-1, Spiderman used 3 swings to reach the tower, and you can easily find out that there is no better way.

             

            Input
            The first line of the input contains the number of test cases K (1 <= K <= 20). Each case starts with a line containing a single integer N (2 <= N <= 5000), the number of buildings (including the apartment and the tower). N lines follow and each line contains two integers Xi, Yi, (0 <= Xi, Yi <= 1000000) the position and height of the building. The first building is always the apartment and the last one is always the tower. The input is sorted by Xi value in ascending order and no two buildings have the same X value.

            Output
            For each test case, output one line containing the minimum number of swings (if it's possible to reach the tower) or -1 if Spiderman can't reach the tower.

            Sample Input

            2
            6
            0 3
            3 5
            4 3
            5 5
            7 4
            10 4
            3
            0 3
            3 4
            10 4
            

             

            Sample Output

            3
            -1
            

             

            Source
            Beijing 2004 Preliminary@POJ

            這是DP題,根據坐標DP是比較好的選擇,提交中wa多次。經回復指點 才注意到建筑物高度相乘越界了 謝謝提醒了

            //Solution by oyjpArt
            #include <stdio.h>
            #include <math.h>
            #include <string.h>
            const int N = 5010;
            const int M = 1000010;
            int x[N], y[N], dp[M], nb;
            const int MAXINT = 2000000000;
            #define Min(a,b) ((a) < (b) ? (a) : (b))

            int main() {
             int ntc, i, j;
             scanf("%d", &ntc);
             while(ntc--) {
              scanf("%d", &nb);
              for(i = 0; i<nb; i++)  scanf("%d %d", x+i, y+i);
              int m = x[nb-1];
              memset(dp, -1, (m+1)*sizeof(dp[0]));
              dp[x[0]] = 0;
              double h = y[0]; 
              for(i = 1; i<nb; i++) { //以1..i的建筑為中介進行飛行
               int d = sqrt(2*y[i]*h - h*h); //不會墜落到地上的最長距離 sqrt(y[i]*y[i]-sqare(y[i]-h))
               for(j = 1; j<=d; j++) { //DP
                if(x[i]-j < x[0]) break; //無用狀態
                if(dp[x[i]-j] == -1) continue; //不可達
                int k = x[i]+j < m ? x[i]+j : m;
                if(dp[k] == -1) dp[k] = dp[x[i]-j]+1;
                else dp[k] = Min(dp[k], dp[x[i]-j]+1);
               }//for
              }//for
              printf("%d\n", dp[m]);
             }
             return 0;
            }

            Feedback

            # re: PKU1925 Spiderman 【DP】  回復  更多評論   

            2007-04-11 15:24 by mark
            int的話相乘后可能越界了

            # re: PKU1925 Spiderman 【DP】  回復  更多評論   

            2007-04-16 20:53 by oyjpart
            謝謝提醒 呵呵
            手机看片久久高清国产日韩| 久久AV无码精品人妻糸列| 国产91久久精品一区二区| 国内精品九九久久久精品| 久久精品综合一区二区三区| 精品一二三区久久aaa片| 久久综合久久综合久久| 亚洲人成无码www久久久| 久久精品人人做人人爽97| 久久久久综合国产欧美一区二区| 亚洲综合伊人久久综合| 伊人丁香狠狠色综合久久| 伊人久久精品无码av一区| 国产亚洲成人久久| 久久亚洲中文字幕精品有坂深雪| 久久久精品久久久久久 | 久久国产精品久久精品国产| 观看 国产综合久久久久鬼色 欧美 亚洲 一区二区| 久久久久亚洲精品无码网址| 粉嫩小泬无遮挡久久久久久| 国内精品久久久久影院薰衣草| 国产精品日韩深夜福利久久| 91精品国产9l久久久久| 性欧美丰满熟妇XXXX性久久久| 久久久久噜噜噜亚洲熟女综合| 亚洲国产精品久久66| 久久久精品免费国产四虎| 精品久久亚洲中文无码| 中文字幕无码久久人妻| 香港aa三级久久三级老师2021国产三级精品三级在 | 精产国品久久一二三产区区别| 国产福利电影一区二区三区,免费久久久久久久精 | 99热成人精品热久久669| 久久久久亚洲AV无码网站| 久久免费看黄a级毛片| 久久久久久久精品成人热色戒| 久久国产精品无| 久久久亚洲欧洲日产国码是AV| 91麻豆国产精品91久久久| 久久人妻无码中文字幕| 性做久久久久久久|