• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            oyjpArt ACM/ICPC算法程序設(shè)計空間

            // I am new in programming, welcome to my blog
            I am oyjpart(alpc12, 四城)
            posts - 224, comments - 694, trackbacks - 0, articles - 6

            PKU1948 Triangular Pastures

            Posted on 2007-02-15 15:51 oyjpart 閱讀(959) 評論(1)  編輯 收藏 引用

            Triangular Pastures
            Time Limit:1000MS? Memory Limit:30000K
            Total Submit:1213 Accepted:291

            Description
            Like everyone, cows enjoy variety. Their current fancy is new shapes for pastures. The old rectangular shapes are out of favor; new geometries are the favorite.

            I. M. Hei, the lead cow pasture architect, is in charge of creating a triangular pasture surrounded by nice white fence rails. She is supplied with N (3 <= N <= 40) fence segments (each of integer length Li (1 <= Li <= 40) and must arrange them into a triangular pasture with the largest grazing area. Ms. Hei must use all the rails to create three sides of non-zero length.

            Help Ms. Hei convince the rest of the herd that plenty of grazing land will be available.Calculate the largest area that may be enclosed with a supplied set of fence segments.

            Input
            * Line 1: A single integer N

            * Lines 2..N+1: N lines, each with a single integer representing one fence segment's length. The lengths are not necessarily unique.

            Output
            A single line with the integer that is the truncated integer representation of the largest possible enclosed area multiplied by 100. Output -1 if no triangle of positive area may be constructed.

            Sample Input

            5
            1
            1
            3
            3
            4
            

            Sample Output

            692
            

            Hint
            [which is 100x the area of an equilateral triangle with side length 4]

            Source
            USACO 2002 February

            由于數(shù)據(jù)量不大 利用可行性的狀態(tài) 進行DP Heron公式
            搜索也能過 呵呵 需要預(yù)先找到一個較好解 大->小搜 加一定的剪枝

            #include <stdio.h>
            #include <algorithm>
            #include <functional>
            #include <math.h>
            using namespace std;
            const int N = 40;
            const int M = 1000; //邊的最大可能長度(三角形性質(zhì))
            bool s[N][M][M];
            int seg[N+1];

            inline double heron(double a, double b, double c) {
            ?double p = (a+b+c)/2.0;
            ?return sqrt(p*(p-a)*(p-b)*(p-c));
            }

            int main() {
            ?int i, j, k, ns, tot = 0;
            ?double best = 0, tmp;
            ?scanf("%d", &ns);
            ?for(i = 1; i <= ns; i++) {?scanf("%d", seg+i);?tot += seg[i];?}
            ?s[0][0][0] = 1;
            ?int bound = tot/2+1;
            ?for(i = 1; i <= ns; i++)
            ??for(j = 0; j<=bound; j++)
            ???for(k = 0; k <=bound; k++)
            ????s[i][j][k] = s[i-1][j][k] || j >= seg[i] && s[i-1][j-seg[i]][k] || k >= seg[i] && s[i-1][j][k-seg[i]];
            ?for(j = 1; j<=bound; j++)
            ??for(k = 1; k <=bound; k++) {
            ???int m = tot-j-k;
            ???if(s[ns][j][k] && j + k > m && j + m > k && m + k > j && (tmp = heron(j, k, m)) > best)
            ????best = tmp;
            ??}
            ?if(best == 0) printf("-1\n");
            ?else printf("%d\n", (int)(best*100));
            ?return 0;
            }

            Feedback

            # re: PKU1948 Triangular Pastures   回復(fù)  更多評論   

            2007-04-22 13:10 by oiuy
            原來是這樣dp的,謝謝~
            久久精品亚洲日本波多野结衣| 久久成人18免费网站| 女人香蕉久久**毛片精品| 久久狠狠高潮亚洲精品| 国产精品久久久久久久久免费| 久久中文字幕一区二区| 精品久久综合1区2区3区激情| 亚洲中文字幕伊人久久无码| 午夜精品久久久久久99热| 国产69精品久久久久99| 久久久网中文字幕| 77777亚洲午夜久久多喷| 久久久久久青草大香综合精品| 久久亚洲AV无码精品色午夜 | 久久久久久精品免费免费自慰| 人妻少妇久久中文字幕一区二区 | 99久久无码一区人妻| 久久久久久久波多野结衣高潮 | 国产一级做a爰片久久毛片| 亚洲伊人久久成综合人影院 | 亚洲国产精品无码久久久蜜芽 | 精品国产一区二区三区久久| 一本色道久久综合狠狠躁篇| 狠狠色婷婷综合天天久久丁香| 国产精品99久久久久久宅男小说| 久久线看观看精品香蕉国产| 欧美日韩精品久久久久| 久久久久国产亚洲AV麻豆| 日本道色综合久久影院| 国产精品久久永久免费| 少妇无套内谢久久久久| 亚洲欧洲久久av| 亚洲欧美精品一区久久中文字幕| 亚洲国产精品婷婷久久| 国产精品视频久久久| 久久国产精品成人影院| 国产成人久久激情91| 91久久精一区二区三区大全| AAA级久久久精品无码片| 人妻久久久一区二区三区| 亚洲国产一成人久久精品|