• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 3,  comments - 1,  trackbacks - 0
              2009年3月8日
                 摘要: 第N道的廣搜,這幾天就準備做廣搜了...真的需要好好練習下... Prime Path Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 187...  閱讀全文
            posted @ 2009-03-08 11:23 生活要低調 閱讀(1440) | 評論 (1)編輯 收藏
              2009年3月7日
            學會了隊列.這道題的主要思想:

            5先入列   把5出列  5 可以變成 4 ,6 , 10, ,把得到的數入列,然后再出列分別處理..如果前面出現過就不入列..定義一個計數數組,然后number[y - 1] = number[y] + 1;  number[y + 1] = number[y] + 1; number[y * 2] = number[y] + 1;

            Catch That Cow
            Time Limit: 2000MS Memory Limit: 65536K
            Total Submissions: 8341 Accepted: 2476

            Description

            Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

            * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
            * Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

            If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

            Input

            Line 1: Two space-separated integers: N and K

            Output

            Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

            Sample Input

            5 17

            Sample Output

            4

            Hint

            The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.




            Source Code

            Problem: 3278 User: luoguangyao
            Memory: 1048K Time: 110MS
            Language: C++ Result: Accepted
            • Source Code
              #include <iostream>
                  #include <queue>
                  using namespace::std;
                  int number[100001] = {0};
                  bool num[100001] = {0};
                  int main()
                  {
                  queue<int> x;
                  int a;
                  int b;
                  scanf("%d%d",&a,&b);
                  int count = 0;
                  number[a] = 0;
                  x.push(a);
                  while (x.size())
                  {
                  int y = x.front();
                  x.pop();
                  num[y] = 1;
                  if (y == b)
                  {
                  break;
                  }
                  else
                  {
                  if (y - 1 >= 0)
                  {
                  if (!num[y - 1])
                  {
                  x.push(y - 1);
                  number[y - 1] = number[y] + 1;
                  num[y - 1] = 1;
                  }
                  }
                  if (y + 1 <= 100000)
                  {
                  if (!num[y + 1])
                  {
                  x.push(y + 1);
                  number[y + 1] = number[y] + 1;
                  num[y + 1] = 1;
                  }
                  }
                  if (y * 2 <= 100000)
                  {
                  if (!num[y * 2])
                  {
                  x.push(y * 2);
                  number[y * 2] = number[y] + 1;
                  num[y * 2] = 1;
                  }
                  }
                  }
                  }
                  cout << number[b] << endl;
                  return 0;
                  }
            posted @ 2009-03-07 18:33 生活要低調 閱讀(1798) | 評論 (0)編輯 收藏
                 摘要: 這題沒把我弄瘋了.一個小時寫完,改了2個小時...題目給的數據太弱了,需要自己寫一些數據來驗證...在這里給大家提供些數據題目 Maze Time Limit: 2000MS Memory Limit: 65536K ...  閱讀全文
            posted @ 2009-03-07 15:14 生活要低調 閱讀(1235) | 評論 (0)編輯 收藏
            僅列出標題  
            <2025年5月>
            27282930123
            45678910
            11121314151617
            18192021222324
            25262728293031
            1234567

            常用鏈接

            留言簿(1)

            隨筆檔案

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

            国产精品久久成人影院| 丰满少妇人妻久久久久久4| 国产国产成人久久精品| 久久精品人人做人人妻人人玩| 久久香蕉国产线看观看精品yw| 亚洲国产精品无码久久久秋霞2| 日产精品99久久久久久| 69久久精品无码一区二区| 一本大道久久a久久精品综合| 色综合色天天久久婷婷基地| 国产午夜精品久久久久九九电影 | 国产精品久久久久天天影视| 久久99热精品| 久久精品这里只有精99品| 亚洲欧洲久久av| 久久午夜无码鲁丝片| 久久国产精品免费一区二区三区| 久久久久久极精品久久久| 亚洲精品国产综合久久一线| 久久99精品久久久久久久不卡| 久久婷婷综合中文字幕| 久久伊人精品一区二区三区| 97久久精品无码一区二区天美| 理论片午午伦夜理片久久| 9久久9久久精品| 99久久免费国产精品特黄| 亚洲精品高清久久| 伊人久久久AV老熟妇色| 久久国产综合精品五月天| 久久SE精品一区二区| 99久久国产综合精品网成人影院| 伊人久久大香线蕉AV色婷婷色| 欧美久久精品一级c片片| 久久久精品国产sm调教网站 | 亚洲欧美日韩久久精品| 久久综合丝袜日本网| 国产精品久久99| 热re99久久6国产精品免费| 精品国产日韩久久亚洲| 亚洲国产一成久久精品国产成人综合| 九九久久99综合一区二区|