• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            一道極其簡(jiǎn)單的ACM題,為什么第2段代碼通不過測(cè)試?
            http://acm.hziee.edu.cn/showproblem.php?pid=1096

            題目
            Your task is to calculate the sum of some integers.

            Input
            Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

            Output
            For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

            Sample Input
            3
            4 1 2 3 4
            5 1 2 3 4 5
            3 1 2 3

            Sample Output
            10
            15
            6

            第一段代碼,通過測(cè)試
            # include <iostream>
            using namespace std;
            int main()
            {
            ?int m,n,s;
            ?int sum;
            ?cin>>n;
            ?for(int i=0;i<n;i++)
            ?{
            ??if(i)
            ???cout<<endl;
            ??cin>>m;
            ??sum=0;
            ??for(int j=0;j<m;j++)
            ??{
            ???cin>>s;
            ???sum+=s;
            ??}
            ??cout<<sum<<endl;
            ?}
            ?return 0;
            }

            第2段代碼,通不過測(cè)試,why?
            #include <iostream>
            #include <vector>
            #include <numeric>
            #include <string>
            #include <sstream>
            using namespace std;
            int main(void)
            {
            int times;
            cin>>times;
            while(times--!=-1){
            ??????? string str;
            ??????? istringstream istr;
            ??????? int temp;

            ??????? getline(cin,str);
            ??????? istr.str(str);
            ??????? vector<int> array;
            ???????
            ??????? bool ignore=true;
            ??????? while(!istr.eof()){
            ?????????? istr>>temp;??????????????????????????
            ?????????? if(ignore==true) {ignore=false;continue;}?????
            ?????????? array.push_back(temp);
            ?????????? }
            ??????? if(!array.empty()) cout<<accumulate(array.begin(), array.end(),0)<<"\n"<<endl;???
            ?}

            return 0;
            }

            有時(shí)候第2段代碼會(huì)得出奇怪的結(jié)果,這是為什么?

            posted on 2006-04-19 01:48 張沈鵬 閱讀(320) 評(píng)論(2)  編輯 收藏 引用
            Comments
            • # re: 一道極其簡(jiǎn)單的ACM題,為什么第2段代碼通不過測(cè)試?
              任我行
              Posted @ 2006-04-20 08:24
              寫的真亂。下面寫法為什么意思?
              bool ignore=true;
              while(!istr.eof()){
              istr>>temp;
              if(ignore==true){
              ignore=false;
              continue;
              }
              array.push_back(temp);
              }
                回復(fù)  更多評(píng)論   
            • # re: 一道極其簡(jiǎn)單的ACM題,為什么第2段代碼通不過測(cè)試?
              me
              Posted @ 2006-04-22 16:04
              就是忽略第一個(gè)數(shù),把string轉(zhuǎn)為int放入vector中  回復(fù)  更多評(píng)論   

            只有注冊(cè)用戶登錄后才能發(fā)表評(píng)論。
            網(wǎng)站導(dǎo)航: 博客園   IT新聞   BlogJava   博問   Chat2DB   管理


             
            国产成人精品久久综合| 久久亚洲AV成人无码软件| 精品国产乱码久久久久久郑州公司| 99久久精品免费看国产一区二区三区 | 亚洲中文字幕久久精品无码喷水| 亚洲第一极品精品无码久久| 国产成人久久激情91| 久久黄视频| 青青青国产成人久久111网站| 欧美亚洲国产精品久久| 久久青草国产手机看片福利盒子| 日批日出水久久亚洲精品tv| 久久99精品国产麻豆| 亚洲成av人片不卡无码久久| 91久久婷婷国产综合精品青草 | 精品综合久久久久久97超人| 久久综合伊人77777| 99久久国产综合精品网成人影院| 久久久久久久91精品免费观看| 久久99国产亚洲高清观看首页| 国产精品99久久久久久宅男小说| 狠狠色丁香久久婷婷综| 男女久久久国产一区二区三区| 亚洲午夜无码AV毛片久久| 久久久精品一区二区三区| 日韩av无码久久精品免费| 国内精品伊人久久久影院| 久久精品国产色蜜蜜麻豆| 99久久成人国产精品免费| 久久久国产精品亚洲一区| A级毛片无码久久精品免费| 久久久这里有精品| 精品熟女少妇AV免费久久| 久久毛片免费看一区二区三区| 国产激情久久久久影院老熟女| 久久精品成人免费看| 国产一区二区精品久久凹凸| 99久久精品国产毛片| 久久精品中文字幕有码| 亚洲国产精品无码久久久久久曰| 久久免费香蕉视频|