• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 74,  comments - 33,  trackbacks - 0

            Description

            Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

            For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

            You are to write a program that will count the amounts of the stars of each level on a given map.

            Input

            The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

            Output

            The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

            Sample Input

            5
            1 1
            5 1
            7 1
            3 3
            5 5

            Sample Output

            1
            2
            1
            1
            0
            神啊原諒我吧我很菜!
            看了樹狀數組還沒思路!
            代碼ac后更新
            posted on 2009-01-10 10:24 KNIGHT 閱讀(173) 評論(1)  編輯 收藏 引用

            FeedBack:
            # re: Stars[未登錄]
            2009-01-12 10:01 | Knight
            #include<stdio.h>
            #define SIZE1 32000
            #define SIZE2 15000
            int c[SIZE1],a[SIZE1],out[SIZE2],n;
            int lowbit(int k)
            {
            return k&(-k);
            }
            int sum(int k)
            {
            int ret=0;
            while(k>0)
            {
            ret+=c[k];
            k-=lowbit(k);
            }
            return ret;
            }
            void change(int pos,int delt)
            {
            while(pos<=SIZE1)
            {
            c[pos]+=delt;
            pos+=lowbit(pos);
            }
            }
            void init()
            {
            int i;
            int x,y;
            for(i=0;i<n;i++)
            {
            scanf("%d%d",&x,&y);
            x++;
            out[sum(x-1)+a[x]]++;
            change(x,1);
            a[x]++;
            }
            }
            int main()
            {
            int i;
            scanf("%d",&n);
            init();
            for(i=0;i<n;i++)
            printf("%d\n",out[i]);
            }
            pip來了,但是他說他也不會他是線段樹過的。。。。。
            線段樹。。。。。代碼不是我的。。。網上的。。。。不過不錯。。。題目有個條件就是按y升序給出數據。。。。所以可以用樹狀數組,其實可以排序在用的。。。。。繼續物理。。。。關機。。。  回復  更多評論
              
            <2008年12月>
            30123456
            78910111213
            14151617181920
            21222324252627
            28293031123
            45678910

            常用鏈接

            留言簿(8)

            隨筆檔案

            文章檔案

            Friends

            OJ

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

            国产精品久久成人影院| 99久久免费国产精精品| 久久精品免费大片国产大片| 国产亚洲婷婷香蕉久久精品| 99国产精品久久久久久久成人热| 日韩一区二区久久久久久| 久久久久久极精品久久久| 噜噜噜色噜噜噜久久| 久久亚洲国产成人精品性色| 四虎国产精品免费久久5151| 久久亚洲国产成人影院| 国产产无码乱码精品久久鸭| 国内精品久久久久| 成人综合久久精品色婷婷| 国产精品视频久久| 人妻无码精品久久亚瑟影视| 青青草国产成人久久91网| 亚洲综合伊人久久综合| 狠狠色伊人久久精品综合网| 亚洲中文字幕无码久久2020| 国产成人精品久久亚洲高清不卡 | 久久精品人人做人人妻人人玩| av国内精品久久久久影院| 久久久SS麻豆欧美国产日韩| 94久久国产乱子伦精品免费 | 久久伊人色| 色成年激情久久综合| 无码AV中文字幕久久专区| 欧美粉嫩小泬久久久久久久| 国内精品九九久久久精品| 亚洲精品美女久久777777| 色综合久久久久综合99| 久久国产精品久久久| 99久久精品国内| 久久―日本道色综合久久| 久久99精品久久久久子伦| 久久精品国产久精国产一老狼| 久久精品亚洲乱码伦伦中文| 99热成人精品免费久久| 久久久国产精品福利免费| 久久久久国产精品嫩草影院|